iCloud Music Videos play audio only?

Discussion in 'macOS' started by inspirations365, Mar 14, 2012.

  1. inspirations365 macrumors regular

    Joined:
    Dec 28, 2008
    #1
    Hello all,

    I was running out of space on my SSD prior to the upgrade I made yesterday, so to get me through the last couple of days, I deleted the music videos purchased from iTunes and matched with iCloud/iTunes match. I did not delete them from iCloud.

    So yesterday I upgraded to a new SSD with double the storage. In my quest to restore my system to prior configurations, I went to re-download the music videos, which seemed to go smoothly, iCloud download icon and all. However, when played, the music videos only play the audio. Okay, fine, I still have them on my iPad and iPhone, I'll just re-sync with those, transferring the purchases. No such luck.

    The iTunes store recognizes I purchased them, but they show up under Music since there is not a section for Music Videos, creating the same issue I'm currently experiencing.

    Does anyone have any ideas about what I can do to restore my music videos to actual videos? They play fine on my iPhone and iPad but not on my MBP.

    Any help is greatly appreciated.
     
  2. inspirations365 thread starter macrumors regular

    Joined:
    Dec 28, 2008
    #2
    Figured it out.

    Music videos re-downloaded from iCloud for some reason have their extensions changed to .m4a. You have to manually change them back to .m4v and they will play fine.

    I feel like a knucklehead for not noticing this earlier.
     

Share This Page