iCloud not sending e-mail from desktop

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by igy4, Sep 24, 2012.

  1. igy4 macrumors newbie

    Joined:
    Sep 23, 2012
    #1
    I am new to MacBooks having had this for a week now. So please bare with me if this seems trivial!

    I have tried sending e-mails from my @me.com address from the mail icon on my Macbook pro desktop but the message sits in my outbox for a while before showing the message

    "Cannot send messages using the server iCloud - Connections to the server “p09-smtp.mail.me.com” on the default ports timed out. Select a different outgoing mail server from the list below or click Try Later to leave the message in your Outbox until it can be sent."

    Now I am receiving e-mails fine at this address and if I log into iCloud.com and send an e-mail from there it works fine, but not when I try doing it from the mail on my desktop.

    Does anyone have any ideas what the problem could be? I would very much appreciate your help!
     
  2. igy4 thread starter macrumors newbie

    Joined:
    Sep 23, 2012
    #2
    Can anyone help at all? Seriously driving me insane!
     
  3. TofSanity macrumors 6502a

    TofSanity

    Joined:
    Oct 29, 2010
    #3
    just noticed I am having the same problem. Also, it was happening on my iOS devices, but I reset the passwords on them and everything was fine, not so on my iMac...
     
  4. TofSanity macrumors 6502a

    TofSanity

    Joined:
    Oct 29, 2010
    #4
    just reset all passwords and now i am receiving and able to send/reply emails from my iMac
     
  5. igy4 thread starter macrumors newbie

    Joined:
    Sep 23, 2012
    #5
    I tried resetting my password on my macbook pro by going to preferences, selecting the account and then deleting the password and typing a new one. Then I click save and I get a message saying that the Incoming mail server field can not be changed. I didn't even touch that field!

    Have tried changing my password on my iPhone too for iCloud and it accepts it but then when I look back there doesn't seem to be as many characters in my password space as my password has? I find that strange!

    But still mail is not sending!
     

Share This Page