iCloud not working fully for me :(

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by Atomant669, Aug 2, 2012.

  1. Atomant669 macrumors regular

    Joined:
    Oct 28, 2011
    #1
    Been having this problem I can never get iCloud to work on all 3 of my devices iPhone 4s, iPad 3rd generation and my MacBook Pro.

    Gosh I don't even know how or where to start telling you guys my problem with iCloud. So, in short, when I key in an appointment in calendar/iPad it gets synced to my iPhone. But when I key in an appointment in calendar/iPhone 4s it doesn't get synced to my iPhone. Can anyone please tell me why?

    I tried gg back to the store I purchase my iPad from (it's a specialist store selling all mac products) and all they can tell me is that 'we don't use iCloud' lol
     
  2. Comeagain? macrumors 68020

    Comeagain?

    Joined:
    Feb 17, 2011
    Location:
    Spokane, WA
    #2
    How long are you waiting for changes to occur? iCloud is not instantaneous, and does require an Internet connection.
     
  3. Atomant669 thread starter macrumors regular

    Joined:
    Oct 28, 2011
    #3
    Well put it the way I have myipad for 2 months now and its calendar is empty other than those appointment I keyed in myself. Most of my appointments are on my iPhone 4s.
     
  4. hafr macrumors 68030

    Joined:
    Sep 21, 2011
    #4
    It sounds like your either have 1 a local calendar on your iPhone that hasn't merged into iCloud, or that you're 2 adding those entries in another synced calendar (such as Gmail) meaning your entries won't ever sync, or 3 that your iPad haven't got all of the calendars activated.

    If you open your Calendar app on your iPhone, then hit the Calendars button in the top left corner. Do you only see a list of iCloud calendars, or do you also have something like "On my iPhone" or anything else other than iCloud? (Birthdays is okay, anything else isn't.)

    1 In the event that you see "On my iPhone", go to Settings > iCloud. Deactivate Calendars in the sync-list, choose remove or save, depending on your on preferences. Then activate and choose "Merge". Now, anything you add should be synced across the board at once.

    2 In the event that you see something that reminds you of another mail account you have set up, go to Settings > Mail, Contacts, Calendars. Under Accounts, you'll have all of your e-mail accounts. Go through them one by one and make sure Calendar is turned off in every single one except for iCloud. Just to make sure it will work, follow the steps in 1.

    3 Should 1 and 2 not be applicable, go to your iPad, open your Calendar app, hit the Calendars button and make sure all calendars are ticked. This will ensure that all calendars are synced across the board.

    Now, if none of this work - I'm all out of ideas... Hopefully it'll help though!
     

Share This Page