iCloud Photo Library won't upload in background

Discussion in 'iPad' started by gsingham, Nov 30, 2015.

  1. gsingham macrumors 6502

    Joined:
    Oct 20, 2013
    #1
    i have an iPhone and Mac both setup for IPL

    Take a pic on iPhone, open Mac and it's already there. Add a pic on Mac and it's there on iPhone before I can even open it.

    Now introduce iPad pro. Add a pic on Mac, wait a day and then leave my house. Picture is on iPhone, picture not on iPad. Return home, open photos app on iPad and in seconds it appears

    So I decided to test it out.

    Take a pic on iPad outside return home to wifi. Pictures are not uploaded to cloud. Go to settings, photos and it says "5 photos to upload"

    Open photos app and upload occurs immediately.

    Anyone else having the same issue.

    In short photos app on iCloud refuses to run in the background.
     
  2. TurboPGT! Suspended

    Joined:
    Sep 25, 2015
    #2
    iCloud Photo Library rarely ever uploads for me in the background on any device. I don't know why. It probably has to meet certain criteria.
     
  3. gsingham thread starter macrumors 6502

    Joined:
    Oct 20, 2013
    #3
    So now apple requires me to open the photos app and wait for my pics to sync before I leave the house? That's a joke. I can understand if ur battery was running low but not otherwise
     
  4. gsingham thread starter macrumors 6502

    Joined:
    Oct 20, 2013
    #4
    I can confirm this is not the intended behaviour.

    Open settings, photos on iPhone

    It will say last updated xx minutes ago...

    Now delete photo or take a photo on the iPad

    Within seconds, it will say on iPhone "just updated"

    And photo library has updated accordingly in the background on iPhone.

    Now try the same thing but vice versa and you will see on iPad, it refuses to update in background.
     
  5. gsingham thread starter macrumors 6502

    Joined:
    Oct 20, 2013
    #5
    Reset network settings have fixed it
     

Share This Page