iCloud Photos Not Saving Photos :(

Discussion in 'iOS 9' started by FSMBP, Aug 18, 2016.

  1. FSMBP macrumors 68020

    FSMBP

    Joined:
    Jan 22, 2009
    #1
    For the past month, I have a 3GB iCloud Photo Library on both my iPad and iPhone (both are 64GB devices with 30+GB free). They are both set to 'download and keep originals' on both devices. However, whenever I tap a picture on my iPhone, I get a low-res version of the photo with a loading-bar. Then, after a minute or so, I get the high-res version.

    Why isn't my iPhone downloading the originals? It's been over a month, both devices get charged at night and have wifi. Whenever I look into settings of both devices, iCloud Photo Library says up-to-date (or whatever).
     
  2. lovewd macrumors 6502

    lovewd

    Joined:
    Aug 28, 2013
    #2
    I keep having iCloud Photo Library issues like this. What works for me is just turning it off and then turning it back on again, which will force it to start downloading the pictures by itself
     
  3. M. Gustave macrumors 68000

    M. Gustave

    Joined:
    Jun 6, 2015
    Location:
    Grand Budapest Hotel
    #3
    1. Have you powered down the phone since the change?

    2. If that doesn't work, you could try turning iCloud Photo Library off and on again.
     
  4. FSMBP, Aug 18, 2016
    Last edited: Aug 19, 2016

    FSMBP thread starter macrumors 68020

    FSMBP

    Joined:
    Jan 22, 2009
    #4
    Thanks all. I will give both suggestions a whirl.

    Edit. I turned off iCloud Photo Library and turned it back on after a reboot. Didn't work.

    Tried it again and it worked. Weird.


    Thanks everyone!
     

Share This Page