iCloud - system wide, all apps failure | Help

Discussion in 'OS X Mountain Lion (10.8)' started by helix21, Nov 20, 2012.

  1. helix21 macrumors regular

    Joined:
    Aug 25, 2009
    #1
    Hi guys,

    My iCloud documents sync is completely broken on the Mac. Pages, Keynote, iA Writer, Byword, Day One... ALL apps that utilise iCloud cant upload new documents or sync changes to those created on my iPhone and iPad. It's a system wide iCloud failure and has been this way for more than a week.

    It has this "dotted cloud" logo next to the recent files that means they are not being uploaded.

    [​IMG]

    I've tried turning off iCloud documents in preferences and rebooting multiple times toggling it to not avail.

    This might have happened after the time I installed the 10.8.2? Anyone experienced the same with 10.8.2 or anything like this before? iCloud is so frustrating when it goes wrong universally since it essentially leaves me handicapped.
     
  2. Jeff3f macrumors member

    Joined:
    Nov 12, 2010
    #2
    I have this too and I'll post back if I learn anything (on hold with apple support now).
     
  3. Jeff3f macrumors member

    Joined:
    Nov 12, 2010
    #3
    I spent a large amount of time on the phone with Apple today, but I fixed my issue.

    To verify if it's the same issue, you can create a new admin user on your computer, then when you login set it up with your same icloud ID (you only need to check the documents in the cloud box). Now, when I did this, and I went into Pages or Keynote, I say my icloud docs just fine. And when I created a test document it showed up in the cloud (verified by looking at icloud.com and also by looking at the docs in the iPhone pages app).

    The fix.

    First, turn off FileVault. (ugh).

    Next, reboot into the recovery partition (power down; hold down command-R while powering on computer). Then, go to the menu bar (top of screen), select "utilities", then select "terminal".

    At the command prompt, type "resetpassword". This brings up an app; toward the bottom it says, "Reset Home Directory Permissions and ACLs" (there's a box there that says "reset"). Click reset, reboot, and try iCloud again. It worked for me.

    This is apparently "industrial strength" permissions repair. iCloud publishing works with a temp folder--your app (Pages or whatever) saves to this file and then it's done; then the Mac's iCloud function syncs this folder with iCloud. If the permissions get mussed up, this fails to occur.

    Good luck, and I hope this helps somebody. If it does, please post and tell us. I had this problem for MONTHs before finally giving up and calling Apple. I found nothing helpful on the web, so hopefully this thread will work. I'll add some keywords to help googlers:

    dotted cloud
    pages keynote do not update upload to icloud
    documents in the cloud does not work
    why are the high-post-count folks on Apple's forums so douchey?

    Thanks! Good luck all!!
     

Share This Page