iCloud won't push to iPhone

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by thaflash, Dec 22, 2011.

  1. thaflash macrumors newbie

    Joined:
    Dec 22, 2011
    #1
    So this is my second Lion related roadblock I'm posting today.

    I actually set up a Genius bar appointment for a Time Machine problem, and loaded it into iCal. iCloud eventually loaded it into it's Calendar. However, my iPhone hasn't received it. I put it into iCloud around 3:00pm PST today, it's now 8:00pm. All the settings on my MBPro are checked, the same with the iPhone. My iCloud account is hooked up to my iPhone, find my iPhone works, contacts are synched and my .me mail is working... but still no calendar.

    This isn't something that I have ever used before, mostly because I didn't trust it to work and I didn't feel I would take the time to make events. But the prospect of push syncing made it seem worthwhile.

    Oh, I also sync'd my phone via iTunes and it still didn't place the event on my iPhone.

    Any ideas?
     
  2. TyWahn macrumors 6502

    TyWahn

    Joined:
    Oct 25, 2003
    #2
    Has it ever worked? And you are SURE that the calendar tab is turned on under Settings/iCloud/Calendar?

    ----------

    You'll also want to check something in iCal.
    In the upper left corner, click on the "Calendars" button. Make sure the "iCloud" Calendar is active when you are setting up the events.
     
  3. thaflash thread starter macrumors newbie

    Joined:
    Dec 22, 2011
    #3
    Everything was checked. Like I mentioned in the original post, everything but iCal worked so it's not like I didn't know how to set up iCloud functions. I was at the Genius Bar and the guy told me to do a restore with the later OS version, and to never update my phone, only download the OS update, backup my phone and do a restore because the update patches cause problems. He also said the cause of my problems with my Macbook Pro was due to doing a Lion update; problems went away when I did a restore with fresh Lion.

    My iPhone restore, was literally a restore from a backup of 1 hour prior. None of my settings had changed and iCal started to work.
     

Share This Page