Icon problems

Discussion in 'Mac Programming' started by Till Roenneberg, Sep 11, 2008.

  1. Till Roenneberg macrumors newbie

    Aug 22, 2008
    I have written many programs on OS9 but I am new to OSX , to objC and to XCode. I have converted a large program from OS 9 to OSX (meaning, I have rewritten it completely) and most of it works fine. I have, however, the strangest problems with the icons assigned to the data files produced by my program. At first the files showed the correct icons but the trouble was any other file in the HD's directory which did not have an icon specifically assigned started to show mine.

    For the last couple of days a new (additional) phenotype occurred. Now my data files don’t show the icon on my computer (MacBook Pro intel) anymore (other non-related files still do). But when I run the same program on a PowerPC, the icons of my data files are correct (the problem with the non-related files also exists there). Both computers run 10.4.1.

    Here are my entries in the properties:
    Name : MyProgram File
    UTI: public.item
    MIME Types: blanc
    OS Types: GODA (this was what I used on OS9; I tried without this but it didn’t help the problem(s))
    Class: blanc
    Icon File: MyIconFileName without extensions
    Store Type: binary
    Role: Editor
    Package: NO

    This is surely a very simple problem and I am obviously making some stupid mistake but I have not found any usable information on the net or in the XCode documentation, so I really would appreciate if someone could help me.

    Many thanks in advance


Share This Page