iPhone Icon Theming: Black border issue

Discussion in 'Jailbreaks and iOS Hacks' started by Happytodd, Sep 30, 2013.

  1. Happytodd macrumors regular

    Joined:
    Oct 19, 2010
    #1
    I decided to do some icon theming yesterday. I previously replaced all my themed icons with the default icons, now I have put all my default icons back and made my themed icons into a Winterboard package.

    There is one issue I am now facing, the far left icon has a black type border/shadow effect, and it is not even transparent using the secondary theme. I have "No Shadows" selected under Springtomize 2 and after a few resprings/reloads/restarts it still has not been fixed.

    I have read I should go into com.apple.mobileicons.framework and rename the AppIconMask to something else, I do not wish to do this as I have quite a few icons that remain unthemed.

    One important thing I like to note though, the app I'm having the problem with is not actually Safari, it is in fact (Google) Chrome with the Safari icon. Could this be the root of my problems. I'm pretty certain it was fine using the first theme since yesterday.

    TD;LR: First icon has black border, unable to resolve.

    Black UPS Darkness Theme:
    [​IMG]

    Glass Glasklart Theme:
    [​IMG]
     
  2. HenryLong macrumors 6502

    HenryLong

    Joined:
    Apr 11, 2013
    Location:
    Germany
    #2
    The problem is due to theming a 3rd party app icon with an Apple app icon.

    Apple 'stock' app icons (Mail, Messages, Safari, etc.) do have the base plate included in the icon file, while 3rd party app icons just need the symbol. For 3rd party app icons, the base plate graphics is included in the AppIconShadow image.

    This means, theming the GoogleChrome app with the (stock) Safari icon results in the themed icon to contain 2 base plates - visible as a black border/shadow in your Black UPS Darkness theme and a darker grey (or less transparent) icon in your Glasklart theme.
     
  3. Happytodd thread starter macrumors regular

    Joined:
    Oct 19, 2010
    #3
    This does make some sense, I just didn't notice it before with the Black UPS theme on a darker wallpaper.

    Is there anyway I could resolve this using the Safari icon as I prefer the Safari one over the Google Chrome ones. I'm still not quite sure why it would not work if the icon size is the same.

    I did read 3rd party icons are a different size but the themed icons are the same as the stock icons.

    Thanks also for the quick reply! :)
     
  4. HenryLong macrumors 6502

    HenryLong

    Joined:
    Apr 11, 2013
    Location:
    Germany
    #4
    Actually it's not a question of size.

    The point is the different design of native Apple icons (w base plate) and 3rd party icons (w/o base plate).

    I'm using Glasklart on all my devices and have created more than 100 icons (especially as Glasklart icons are not available for iPad mini).

    I've just modified the Safari icon by removing the base plate. Replacing your current Glasklart icon with the attached one will solve your issue.
    Since I only use Glasklart, I don't know how icons are created/modified for your 2nd theme.
     

    Attached Files:

  5. Happytodd thread starter macrumors regular

    Joined:
    Oct 19, 2010
    #5
    Oh, I see what you mean with the base plate now.
    I appreciate all the trouble you have gone through to make the icon work for me, unfortunately though it seems the transparency is out as the whole icon has now gone black.

    I even attempted to remove "com.apple.mobileicons.framework" from the theme to see if that would fix it, it had no affect on anything.

    [​IMG]
     
  6. HenryLong macrumors 6502

    HenryLong

    Joined:
    Apr 11, 2013
    Location:
    Germany
    #6
    You should not delete the 'com.apple.mobileicons.framework' folder.
    In fact, the images included in this folder are especially created to eliminate the black icon background.

    I may have checked earlier, but what device & firmware are you running?
     
  7. Happytodd thread starter macrumors regular

    Joined:
    Oct 19, 2010
    #7
    I'm using my iPhone 4 on iOS 6.1.

    On a side note, I decided to put the Glasklart Chrome icon back on again just then, to my surprise it is still having the same problems, it has the same black background like your edited version. No black border just the whole icon is black besides the Chrome logo.

    Would you have any idea what might be causing this, I might do a reinstall of Chrome.

    Every other Glasklart icon is working perfectly, I have put everything back to normal even running the "com.apple.mobileicons.framework" that came with the Glasklart theme.
     
  8. HenryLong, Oct 2, 2013
    Last edited: Oct 2, 2013

    HenryLong macrumors 6502

    HenryLong

    Joined:
    Apr 11, 2013
    Location:
    Germany
    #8
    Actually, I have no clue - never faced a problem like yours before.

    Have you tried a full reboot instead of a respring?
    Although Winterboard works with respring, a reboot sometimes helps.

    My next try would be to uninstall Chrome as suggested by you.
    Prior to reinstallation I would recommend to manually search and delete all leavings of Chrome using iFile and to run iCleaner as well.
     
  9. Happytodd thread starter macrumors regular

    Joined:
    Oct 19, 2010
    #9
    Still not fixed.

    I uninstalled, then reinstalled.

    I then uninstalled, installed iCleaner which got rid of 1.3gig of stuff. Then reinstalled Chrome. I've tried the icon offered in Glasklart and the icon you specially made.

    I even checked for left over files using iFile after I ran iCleaner, cannot find any traces left over.

    I'm puzzled at the moment and I think we have exhausted all options. I'll keep playing around with it though, something is definitely up with it!
     
  10. Happytodd, Oct 3, 2013
    Last edited: Oct 3, 2013

    Happytodd thread starter macrumors regular

    Joined:
    Oct 19, 2010
    #10
    The icon you gave me no longer works. If I just have it enabled it shows the default Chrome icon. I even replaced the default icon in SHH instead which didn't work either. Using the default icon shows no shadowing effect or anything.. Damn you Google! =P

    EDIT:
    I came across the following link, this particular person was having the same issue with any app icon that started with a capital letter. Unfortunately I cannot simply change it to a lower case letter, again I'm stuck!
    http://modmyi.com/forums/winterboard/725340-icon-transparency-bug.html
     
  11. HenryLong macrumors 6502

    HenryLong

    Joined:
    Apr 11, 2013
    Location:
    Germany
    #11
    This link refers to a problem under iOS4.x. I've never experienced similar issue under iOS6.

    In order to check myself, I've just installed Chrome.
    The Glasklat icon showed up right away. No borders, no dark shadows.
    Replaced the icon with the created Safari icon and it works perfect as well.
    (modified the icon name to start with a capital 'I' but you probably did this as well)

    From my end I can only assume that your problem is neither related to the Chrome app nor to the created Safari icon.

    Something in your system must have cached the original icon image of Chrome, so that Winterboard is not able to properly overwrite it.
    Do you have Chrome linked to any other app(s) - i.e. use Chrome as the standard browser instead of Safari and/or integration of Chrome in other Google apps?
    If so, you should deactivate all such links to Chrome, then deinstall and redo the search on any leavings.
    There must be something left that keeps the original icon image cached.
     
  12. Happytodd thread starter macrumors regular

    Joined:
    Oct 19, 2010
    #12

    I cannot thankyou enough for the time you have invested in my problem, and going as far as to install the same app. :)

    I don't know why I didn't think of this before, I have two tweaks, 1. BrowserChooser and 2. Chrome Download Manager. I disabled both using Springtomize 2 and still did not work, I do think we are on the right track with a conflicting tweak though.

    The icons do change we are just having a problem with the transparency.
     
  13. IrishVixen, Oct 3, 2013
    Last edited: Oct 3, 2013

    IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #13
    Edited to add: a little more digging turned up this, an update to how the black icon fix is handled:

    https://github.com/glasklart/hd/issues/87

    I'm assuming you have similar files already your Glasklart theme folder, have you checked to be sure there are no files with the same name in any other themes you have checked in WB? That's typically a common problem with theming. I'll keep digging to see if I find anything else...now I'm curious. :)

    ---previous post left for reference--

    I haven't used it recently, but Glasklart has required for many iOS revisions now that you rename a system file in order to get rid of that black icon background behind your transparent icons. As far as I'm aware, there hasn't been another solution since iOS 4.1. While I understand the issue you have with using it, because I have unthemed icons too, this is just part of using Glasklart.

    You can search either Google or this forum and find dozens of posts about it, with no other viable solution provided. Here's one with simple instructions, it's a 20 second fix:

    http://forums.macrumors.com/showthread.php?t=1312044

    Be sure to rename the file, not delete it. You will want to rename it back if/when you next change icon sets.

    I have just confirmed on my own phone that following the directions in the first post of the linked thread still works correctly to remove the black icon mask on iPhone 5/iOS 6.1, and should work on an iPhone 4 or 4S as well. And you'll still probably need to use the modified icon for Chrome that HenryLong has provided.

    (And yes, this is the main reason I stopped using Glasklart. It's gorgeous, and it's too bad that Apple doesn't support a transparent theme. Wonder what might change on that front for iOS 7?)
     
  14. HenryLong macrumors 6502

    HenryLong

    Joined:
    Apr 11, 2013
    Location:
    Germany
    #14
    Interesting idea!

    And yes, the 'com.apple.mobileicons.framework' folder included in the Glasklart theme just contains the images to eliminate the black icon background as well as shadow.

    @Happytodd: If you have installed any other theme that affects icons and/or springboard just make sure to have the Glasklart Icons folder at the very top in the Winterboard theme list.

    But, since I understand there's only this one icon affected, I doubt this to solve the problem.
     

Share This Page