icons chaos went in order

Discussion in 'macOS' started by zoran, Feb 6, 2011.

  1. zoran macrumors 68030

    Joined:
    Jun 30, 2005
    #1
    i like my desktop icons scattered and organized customly (the way i want them to) so as you can understand i have an icon chaos on my desktop and thats the way i like it, but this is the 2nd time that when i opened my iMac the chaotic arrangement of my icons was put in order and guess what i went bananas :eek:
    i like my icon chaos and i have no idea why this happened, can anyone help?
     
  2. zoran thread starter macrumors 68030

    Joined:
    Jun 30, 2005
  3. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #3
    maybe no one knows how to help that should not happen obviously how are they ordered by name or date created or what shouldIleaveoutthespacestoo ;)
     
  4. RubyRoses, Feb 16, 2011
    Last edited: Feb 16, 2011

    RubyRoses macrumors newbie

    Joined:
    Feb 13, 2011
    #4
    When you say 'second time', presumably this has happened ever since you started to 'chaotically arrange' shall we say?

    I have this feeling the mac is instructed to automatically order all icons everywhere on its system - on the desktop, in folders etc...

    Perhaps try right-clicking your desktop to bring up the list of options, click 'Show View Options' and see if 'Snap to grid' or 'Keep arranged by' are selected...?
     
  5. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #5
    Seriously, I had a look on my Mac. (wasn't there before)

    Open your Home folder. Open Show View Options. What is it set to Arrange By? That is the enclosing folder for your Desktop folder. It may be dictating to the OS what to do on the Desktop in your account.

    Now open the Desktop folder. Open Show View Options again. What is it set to Arrange By? Set it to what you want; Snap to Grid or None. Close it.

    Wait a few days, and report back.
     
  6. zoran thread starter macrumors 68030

    Joined:
    Jun 30, 2005
    #6
    In the home folder (i assume home folder is the account name folder) in show view options, it is set to arrange by NAME. Of course there is no NONE setting there. Ok in the desktop folder i have set it to NONE and im still waiting. But now that i come to think of it, isnt it strange to have the exact similar settings on my laptop and my desktop "icon chaos" hasnt been disturbed yet?
     
  7. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #7
    Correct assumption, incorrect conclusion. Click the up/down triangle. None should be there. If it's not, you've got bigger problems than an orderly Desktop.
     
  8. zoran thread starter macrumors 68030

    Joined:
    Jun 30, 2005
    #8
    things aren't so dramatic, no worries
    there is no NONE -as you can see- because im in Column view mode, so ok i switch to icon view mode and now i can see NONE, then what do i do?
     

    Attached Files:

  9. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #9
    The "None" selection is not available on the user's Home folder, but is available in sub-folders.
     
  10. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #10
    I stand corrected. Never noticed that before, and had no reason to assume it was different than other folders. Plus, setting that for the Desktop Folder, as I suggested before, is probably only going to affect that finder window, not the actual Desktop.

    How about creating a new Desktop plist file?
     
  11. zoran thread starter macrumors 68030

    Joined:
    Jun 30, 2005
    #11
    thanx i tried that and after 3 days that you made this proposition to me, today, all went in order again, why am i having the feeling that this is either a OSXbug, or there is something wrong with my iMac!
    Guys help im going bananas over this, everytime i have to scatter my icons the way i want to! :(
     
  12. zoran thread starter macrumors 68030

    Joined:
    Jun 30, 2005
    #12
    Is there someplace else i can notify of this issue cause having posted it so long in here without a solution to be found, kinda sounds to me like a bug, don't you think?
     
  13. patp Guest

    Joined:
    Apr 10, 2008
    #13
    sjobs@apple.com
     
  14. zoran thread starter macrumors 68030

    Joined:
    Jun 30, 2005
    #14
    it been so long and i haven't been able to find a way to solve this issue, anything else apart from that email patp send me which i dont really think im gonna get a answer
     
  15. zoran thread starter macrumors 68030

    Joined:
    Jun 30, 2005
    #15
    ok so let me put it another way.
    Suppose all day i have been working on my iMac and at around 15.00 i finish and shut it down. How does the computer remember every time it begins which was the way i that i placed those icon desktops?
    Is it all software, or might there be a small charging device/battery that just isn't working as it should and thats the reason why my icons every now and then loose their placement memory?
     
  16. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #16
    Nah! It's a software thing. Have you tried a different Account? Put some icons on the Desktop and log out and back in. Maybe you just need to move beyond your present account.
     
  17. zoran thread starter macrumors 68030

    Joined:
    Jun 30, 2005
    #17
    what does "to move beyond" mean?
     
  18. bobotech macrumors newbie

    Joined:
    Sep 29, 2011
    #18
    He probably means to create a new local account (admin most likely) and then migrate to that account. Copy your data over to that new account and see if the problem reoccurs again. Simple enough troubleshooting step. if the problem occurs on all local accounts, then most likely the problem lies with the system. If it only occurs on your one accout and not the other account, then its a problem with the first account.

    Did you do permissions repair by any chance?
     
  19. zoran thread starter macrumors 68030

    Joined:
    Jun 30, 2005
    #19
    no i didn't do permissions, but what exactly do they do?
     
  20. bobotech macrumors newbie

    Joined:
    Sep 29, 2011
    #20
    Open up Disk Utility from your Utilities folder. Once in Disk Utility, highlight your hard drive on the left hand pane (upper). In the right side, click on the First Aid tab. Then click on Repair Disk Permissions.

    That might help if the setting for the icon arrangement has improper permissions causing this issue to occur. I am grasping at straws here though but it can't hurt to do the permissions repair.
     
  21. zoran thread starter macrumors 68030

    Joined:
    Jun 30, 2005
    #21
    now that you mention it, there are some folders on my desktop that need admin l/p to be deleted or moved because they were transferred there from a different system, maybe these need permissions fix?
     
  22. zoran thread starter macrumors 68030

    Joined:
    Jun 30, 2005
    #22
    i did a permissions fix through disk utility but this didnt solve it, icons went into arrangement again, this is very frustrating :(
     
  23. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #23
    Did you try that? I removed the final question which seems to have distracted you.
     
  24. zoran thread starter macrumors 68030

    Joined:
    Jun 30, 2005
    #24
    i didn't try this no, but i fear of doing it, i have so many data and im afraid to make migrations n transferings now
     
  25. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #25
    Yeah, you need to be careful. Just don't delete the old account until you're confident that everything is moved. But, if this icon problem is eating at you (and it seems to be an old issue) this might be the quickest way to fix it, if it works. There's no harm in finding out. If you create the second account, log in using it, and it's no better, then you can trash the new account without touching your files. Then you're back to square one.
     

Share This Page