Icons in theme not working

Discussion in 'Jailbreaks and iOS Hacks' started by cclloyd, Jan 29, 2012.

  1. cclloyd macrumors 68000

    cclloyd

    Joined:
    Oct 26, 2011
    Location:
    Alpha Centauri A
    #1
    I downloaded Glasklart HD for my 4S, and most of the icons work, but some that I know are there aren't working, like the mail, or music icon. I even checked in iFile, and the icons ARE there.

    I also tried rebooting/respring to make it work, but it didn't.

    So how can I fix the icons?
     
  2. htownmade1984 macrumors regular

    Joined:
    Aug 5, 2010
    #2
    having the same problem with G.O.C. Pro. The Dock music icon is the wrong one, tried to fix it using iFile, but it didn't work
     
  3. imalazeeass macrumors regular

    Joined:
    Feb 7, 2011
    #3
    when u say not working is it a blank icon or the stock icon?
     
  4. cclloyd thread starter macrumors 68000

    cclloyd

    Joined:
    Oct 26, 2011
    Location:
    Alpha Centauri A
    #4
    Stock icon. It shows normal icons. I can screenshot if you want.
     
  5. oscarc macrumors newbie

    Joined:
    May 8, 2011
    #5
    My suggestion would be to look at the Glasklart thread, which should be on the first page. One of the last posts is to a recent bundle for iOS 5. Download the .rar file and replace the existing Glasklart folders on your phone. See if the stock icons are now themed.

    To be safe, you can always copy the existing folders from your phone to your computer as a backup, in case something goes wrong.
     
  6. cclloyd thread starter macrumors 68000

    cclloyd

    Joined:
    Oct 26, 2011
    Location:
    Alpha Centauri A
    #6
    Didn't work. And I just tried to change the maps icon to an alternate one that was in the theme, so I swapped out the icons, and now the map icons is the default one too.
     
  7. oscarc macrumors newbie

    Joined:
    May 8, 2011
    #7
    Weird. Can you list everything you have checked off currently in Winterboard?
     
  8. cclloyd thread starter macrumors 68000

    cclloyd

    Joined:
    Oct 26, 2011
    Location:
    Alpha Centauri A
  9. oscarc macrumors newbie

    Joined:
    May 8, 2011
    #9
    I have HD GUI and HD Folders checked as well. The newest bundle should have a HD Badges #2, which should be used instead of HD Badges.
     
  10. cclloyd thread starter macrumors 68000

    cclloyd

    Joined:
    Oct 26, 2011
    Location:
    Alpha Centauri A
    #10
    That was not listed. Where can I download it?

    And I originally had folders checked, but took it off cause it looked bad. Any way I can make the folders translucent-ish like other icons? I heard someone already made this.
     
  11. oscarc macrumors newbie

    Joined:
    May 8, 2011
    #11
  12. cclloyd thread starter macrumors 68000

    cclloyd

    Joined:
    Oct 26, 2011
    Location:
    Alpha Centauri A
    #12
    Fail question, but how do I install them from my computer? I have iFile if I can need to just transfer them somewhere.
     
  13. oscarc macrumors newbie

    Joined:
    May 8, 2011
    #13
    Just extract the .rar to your desktop or anywhere else on your computer. Use WinSCP or a similar FTP program and connect to your phone. Transfer the files from where you extracted them to the var/stash/themes folder.

    I would suggest deleting first the existing glasklart folders from your phone first, to ensure you are installing a fresh copy of all the files.

    If you have never done any of this before, just do a search on Google on how to transfer files to your iPhone. HTH
     
  14. HickDead macrumors 6502a

    HickDead

    Joined:
    Dec 2, 2011
    #14
    Is there a reason WHY this 'Glasklart HD' theme is such a PITA?

    I've downloaded and installed a bunch of themes and NONE are as complicated and problematic as Glasklart.

    If a theme requires this much tweaking, then IMO it's just not worth it. In fact, it's not all that to begin with.

    Did the author abandon updating it or something?
     
  15. cclloyd thread starter macrumors 68000

    cclloyd

    Joined:
    Oct 26, 2011
    Location:
    Alpha Centauri A
    #15
    Ah, now it worked after I installed that package. Thank you.

    Still, some icons aren't working, but that's cause they aren't in the theme :p
     

Share This Page