ICONS missing! trackpad out of control!

Discussion in 'MacBook Pro' started by 314Jason, Oct 16, 2011.

  1. 314Jason macrumors newbie

    Joined:
    Oct 16, 2011
    #1
    Hi, I've been using my mac smoothly for 14 months. But until recently it has been acting very weird. Here's the sequence of events:

    1. Parts of the track pad stopped working (I can only use the bottom half)

    I restarted the computer.

    2. Then the cursor jumps around (even with a mouse)
    3. It starts clicking and right clicking on its own

    I freaked out, so I ran a software update, and managed to use Disk Utility to verify and repair disks then restart.

    4. The track pad seems to be working better (but a little jumpy at times), BUT all the basic icons are gone (e.g. Applications folder and downloads folder becomes a "?" while other folders on the desktop appear invisible)
    5. I went to CandyBar (an icon modification app). But under "General Icons", there isn't even anything to replace. Like usually there'll be the normal default icon, so I can simply drag and drop a modified icon over it.
    6. The cursor is jumpy again, it keeps selecting stuff and clicking stuff.

    Background: Macbook Pro 13" Version 10.6.8 Snow Leopard. Processor: 2.4 GHz Intel Core 2 Duo. Memory: 4 GB 1067 MHz DDR3.

    I recently installed a torrent app called frostwire. It doesn't seem safe, considering the last I downloaded limewire on my PC, it gave me a bunch of nasty viruses. Could this be a virus issue?

    Please help!
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Macs are not immune to malware, but no true viruses exist in the wild that can run on Mac OS X, and there never have been any since it was released 10 years ago. The only malware in the wild that can affect Mac OS X is a handful of trojans, which can be easily avoided with some basic education, common sense and care in what software you install. Also, Mac OS X Snow Leopard and Lion have anti-malware protection built in, further reducing the need for 3rd party antivirus apps.
     
  3. yusukeaoki macrumors 68030

    yusukeaoki

    Joined:
    Mar 22, 2011
    Location:
    Tokyo, Japan
    #3
    Seems like Macs problem since there is no virus for Mac.
    And as said, there is anti-maware protection on SL/Lion.

    Turn on firewall if you're worried.
     
  4. 314Jason, Oct 16, 2011
    Last edited: Oct 16, 2011

    314Jason thread starter macrumors newbie

    Joined:
    Oct 16, 2011
    #4
    Thanks for the replies. So its probably not a malware/virus problem.

    Here's an update:

    1. The trackpad seems to be working normally now, but after 30 mins or so it'll start clicking and moving erratically again. Sometimes, parts of the trackpad just doesn't work: Here's an example (this is a chinese writing pad I used to test the trackpad)

    [​IMG]

    I tried moving it around and found an unresponsive band on the trackpad (top section)

    [​IMG]
    This is me drawing a diagonal. You can see it doing weird stuff on top and again near the bottom.

    I tried using a USB connected mouse instead, and it worked fine for a while. Then it'll start clicking and moving around again for about 5 seconds. My bluetooth and airport is off btw.

    [​IMG]
    Then I tried drawing lines from the bottom up, and when I get to the top, it starts jumping around again!

    2. The icons are still missing. I tried reinstalling CandyBar and restoring the default icons to no avail. There are simply no wells to even modify the general icons. Here's what I mean:

    [​IMG]
    This is Finder>Preferences>Sidebar. A lot of the icons disappeared!

    [​IMG]
    Same here, some icons are gone. I made the 'ebooks' and '.icn' icons. That's when I though maybe CandyBar didn't backup my default icons, so when I tried to restore it, it just becomes blank. I don't really care if I have the default icons or not because I have the modified icons I want to replace.

    [​IMG]
    But in CandyBar, there isn't even any wells in this section! There were supposed to box things (like under the 'Folder icons'). So I can't replace or modify the icons or anything. It's like the actual "places" for the icons don't exist!

    [​IMG]
    No well here either :(

    [​IMG]
    This's what it's supposed to look like!

    [​IMG]
    This is he info box for my movies folder.

    Oh and I already tried deleting the com.apple.desktop.plist and com.apple.finder.plist files.

    PLEASE! Somebody help! I figured the trackpad and the disappearing icons must be separate issues.
     

Share This Page