Icons turn white after trying to customize through SSH

Discussion in 'Jailbreaks and iOS Hacks' started by redbeard331, Aug 31, 2010.

  1. redbeard331 macrumors 6502a

    redbeard331

    Joined:
    Jul 21, 2009
    #1
    I'm stumped by this one, note it has nothing to do with the problerm some people have where random white icons appear after installing some JB apps. This happens when I install my own icons I made using Winscp and SSH. I'm just renaming the icons to icon.png or icon@2x.png or whatever their name is, which worked until yesterday, any help would be greatly appreciated!!

    I've found it more difficult to do this sort of thing on the iP4 than my old 3G..:eek:
     
  2. Hype2k2 macrumors 6502

    Hype2k2

    Joined:
    Jul 14, 2010
    Location:
    Houston, Texas
    #2
    SBSettings bug I believe, search forums.

    I think the only fix is to uninstall SBSettings or just respring when it happens. It's not really a big deal.
     
  3. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #3
    I don't think this is the same issue (which is a bug in libhide, not in SBSettings, by the way). That bug unhides hidden applications, including some natively hidden ones without icons, which then appear white. The OP seems to be saying that when he copies icons for non-hidden apps over to his phone the icons for those apps then appear white.
     
  4. redbeard331 thread starter macrumors 6502a

    redbeard331

    Joined:
    Jul 21, 2009
    #4
    And you are correct..

    I've had no problem making my own icons for over a year now, so this really has me stumped, so far it seems to only affect the apple icons like Safari, Messages, Appstore, and Ipod, etc..

    :confused:
     
  5. redbeard331 thread starter macrumors 6502a

    redbeard331

    Joined:
    Jul 21, 2009
  6. mrathee macrumors 6502

    Joined:
    Jul 8, 2010
    #6
    I had this issue with my ipad as well. my problem was the fact that I had icon.png, icon@2x, icon@75 and a few others in each folder

    I was foolishly only replacing one and leaving the rest.

    instead, I deleted them all and put in the new icon ALONE

    This solved the problem for me.
     
  7. redbeard331 thread starter macrumors 6502a

    redbeard331

    Joined:
    Jul 21, 2009
    #7
    Thanks for the feedback, will try it out..

    Well that didn't work either, I just don't get it, last week it worked so easily, now it's just impossible, there has to be a way!!
     
  8. redbeard331 thread starter macrumors 6502a

    redbeard331

    Joined:
    Jul 21, 2009
    #8
    I've tried every method I can think of, google has been no help, there has to be a setting or something that I'm just missing, anybody know of a detailed, step by step, tutorial for iOS 4 that might be of help???

    Edit: Figured it out!!! I think it was a combo of me putting them in the wrong location and using the wrong method..

    Thanks to everyone who helped!
     
  9. iphonetheme macrumors newbie

    Joined:
    Aug 11, 2010
    #9
    I notice that there is a windows software named iSpirit. They said install deb ipa files through it would not appear white icon, it can also fix the appeared white icon. try it.
     
  10. FamiliaPhoto macrumors 6502a

    FamiliaPhoto

    Joined:
    Jul 24, 2009
    Location:
    Chicago, IL
    #10
    I'm having the same issue with two icons I did for the Glasklart theme (paper toss and Chase). Strange thing is they are fine in other themes like Suave HD using the sme bundle and file names, they just won't work in Glasklart. And to make it even stranger, Chase was fine till this morning, it themed with no issue.

    Any thoughts' I'm stumped.
     

Share This Page