iCould Mail is SO BAD I want to break my MacBook!

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by nampramos, Oct 28, 2011.

  1. nampramos macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
    #1
    Seriously, what is wrong with this?

    I have deleted my account so many times from my Mac and still it doesn't work.

    Why the hell does it ask for my password everytime I try to send some mail and then it doesn't even accept it! The server always denies it!

    The password is RIGHT! It works on the iPhone (sometimes!).

    I can't even add another smpt server to the iPhone. It says it accepted the one I added but then it never gets added to the server list!

    Already deleted account from the iPhone as well, nothing changed!

    Everything works perfectly, I love the photo stream and the synching of all my contacts and calendars.

    But this mail really sucks and right now it is the biggest pain in the ass I can remember!

    I want to slap someone with my MacBook!
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    Then don't use it. Sounds like you have a configuration error, which wouldn't be iCloud's fault.
     
  3. szolr macrumors 6502

    Joined:
    Jul 27, 2011
    Location:
    London, UK
    #3
    ^ Something like that, yes. I've not experienced anything of what you describe.

    Oh, and I recommend you don't break your Macbook. You'd probably regret it later. :cool:
     
  4. Macsterguy macrumors 6502a

    Macsterguy

    Joined:
    Jun 5, 2007
    Location:
    Texas
    #4
    Sometimes deleting accounts isn't the answer...

    Do this - Go to apple mail preference / accounts and see if your servers & passwords are in place there. I will bet you a dollar that some of the items are blank and need to be filled in...

    Fix mail first then sync your iPhone...

    The prompt to enter a password may keep popping up as you try to do this... Just keep canceling out of that and check all entries.
     
  5. nampramos thread starter macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
    #5
    You might thin I don't know what I'm doing, but think again.

    All fields are filled in and correct.

    I've been having this problem since day one so I had a lot of time to double check, triple check,... million check.

    I'm sure I'm not the only one with this problem. But I'm probably the only one still trying to make it work. All the others just moved on...
     
  6. WesCole macrumors 6502a

    Joined:
    Jul 1, 2010
    Location:
    Texas
    #6
    Every now and then I get the password error. I just chalk it up to it being fairly new and Apple trying to work out the bugs. Every time it happens, I keep hoping the servers are just being reset to launch iTunes Match. :)
     
  7. johnhurley macrumors 6502a

    johnhurley

    Joined:
    Aug 29, 2011
    #7
    Is that anything like "hit me with your rhythm stick?" ... ( sorry old reference ).

    You might be able to do it on video and put it up on youtube and make a whole bunch of money going viral.

    On the other hand it might be lawsuit city!
     
  8. phinsup macrumors 6502

    phinsup

    Joined:
    Sep 19, 2008
    Location:
    SE Florida
    #8
    I had this issue with my wife's converted account. Turns out in apple mail under outgoing server it just had username not username@me.com. As soon as I filled that in it worked fine. Hope it helps.
     
  9. nampramos thread starter macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
    #9
    Its not that. Still keeps asking me for my password when I try to send an e-mail.

    Incoming work fine. Outgoing just does not work.

    Very annoying!
     
  10. linkstate macrumors newbie

    Joined:
    Dec 9, 2006
    #10
  11. nampramos thread starter macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
    #11
    My password has always covered that aspects. Thanks, it's not that.
     
  12. Macsterguy macrumors 6502a

    Macsterguy

    Joined:
    Jun 5, 2007
    Location:
    Texas
    #12
    Mine is great. Just trying to help... delete all accounts, reboot, and recreate them on all devices.
     
  13. YoYoCome macrumors newbie

    Joined:
    Apr 17, 2010
    #13
    I believe the problem lies within Apple's server. This happens on my iPhone too. Sometimes when I am checking emails, it'll pop up a warning saying my password is incorrect for my @Me email.
     
  14. nampramos thread starter macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
    #14
    I also don't think the problem is on my end.
    It is just Apple servers that aren't 100% and some users are experiencing problems.
    I already deleted accounts in both Mac and iPhone. Nothing changed with that.
     
  15. tigres macrumors 68040

    tigres

    Joined:
    Aug 31, 2007
    Location:
    Land of the Free-Waiting for Term Limits
    #15
    Same exact thing on my wife's MB running that POS lion OS.

    I had to go into apple id online and reset her password after moving her to that POS iCloud.

    She still can't send her smtp mail on her account. Bugs my ass. This is simple mail people, not rocket science.

    Works on iPad, works on iPhone, works on iCloud online, does not work on lion.

    Pain is the ***. I am so sick of trying to fix what is supposed to just work.
    Deleted account.
    Changed password
    Rebooted
    Repaired permissions
    Rebooted
    Set up new mail
    Rebooted
    Said prayer
    Checked mail. Ok
    Send mail. Password wrong
    Check password in outgoing
    User and password correct
    Re type password
    Re type user name
    Save settings
    Close mail
    Reopen mail
    Delete outbox mail
    Try again
    F'n fail
    Password incorrect

    So much fun. She just wants to email, sorry honey you can't. Just use your work account I guess. Or iPhone.

    She gets more pissed every day on this. The iCloud chat is next again. So much win on mail I can't take it. /s
     
  16. fenskezen macrumors regular

    Joined:
    Feb 6, 2011
    #16
    Been having the same sorts of problems. Did all of the above.

    Here is the one thing that I have figured out:

    There are times when it works perfect..for a day or two even. That tells me my settings are correct.

    I have very slow internet at home. ( air card, live out in the boondocks)
    When my internet is running good and fast my iCloud stuff works good. Email's come and go..no password issues. But when my internet is slow, the problems start. That tells me that maybe those that are experiencing problems have slow internet speeds?

    Today, right now, my internet is zipping along...icloud is working great and so is the mac.com email.

    Is there anyone out there with good internet all the time that have these problems?
     
  17. jkeekij macrumors regular

    Joined:
    Oct 17, 2011
    #17
    Have you tried to repair the keychain, or delete the entry for your mail account and let it recreate after you are asked to enter your password again?
     
  18. tigres macrumors 68040

    tigres

    Joined:
    Aug 31, 2007
    Location:
    Land of the Free-Waiting for Term Limits
    #18
    24 MB connection on uverse. Fast. No go.
     
  19. nampramos thread starter macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
  20. fenskezen macrumors regular

    Joined:
    Feb 6, 2011
    #20
    Thanks for the input...must be just a coincidence. I tend to blame most everything on my slow internet.

    That said..icloud .mac mail seems to be working today for me. Anyone else?
     
  21. tigres macrumors 68040

    tigres

    Joined:
    Aug 31, 2007
    Location:
    Land of the Free-Waiting for Term Limits
    #21
    Please detail what you mean here. No idea why I would have to dig into keychain access. How does one "repair" keychain access?
     
  22. jkeekij macrumors regular

    Joined:
    Oct 17, 2011
    #22

    Mail is going to store the login information in the keychain, and if that entry has an issue it can cause the email program to ask for the password all the time.

    Applications>Utilities>Keychain Access

    You can use keychain first aid from the menu, and verify and repair the keychain. If you still have issues you can delete the key for mail and let it recreate.
     
  23. nampramos thread starter macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
  24. tigres macrumors 68040

    tigres

    Joined:
    Aug 31, 2007
    Location:
    Land of the Free-Waiting for Term Limits
    #24
    No problems found. But I deleted mail keychain. Started again as above. Same issue sending.
     
  25. jkeekij macrumors regular

    Joined:
    Oct 17, 2011
    #25
    Well, that is strange. I have had this issue and it is frustrating. If you are on a portable, does the sending problem occur on every network that you are on?
     

Share This Page