Icy Dock HDD Enclosure/WD HDD combo not recognized

Discussion in 'iMac' started by Seo, Oct 8, 2010.

  1. Seo macrumors regular

    Joined:
    Jun 1, 2009
    Location:
    Cupertino, California
    #1
    I just ordered an Icy Dock MB662USEB-2S dual bay external hard drive enclosure (the successor of the MB662UEAB-2S) along with two of Western Digital's newest SATA III drives, the 1TB WD 1002FAEX HDD. As the SATA standard is backward compatible and my seller confirmed that the two would work without an issue, I presumed they would. And indeed, when I first placed the two drives inside the enclosure and hooked it up to my iMac with another external drive daisy chained, everything went find. I formatted the drive and began transferring files without any issues whatsoever.

    The next day, I turned on my computer and then my drive enclosure and it didn't show up. After a long while, it did and I went about using it until the next day, it didn't show up at all. Today, the drive isn't being recognized by the computer at all. Nothing in Disk Utility.

    I've checked all the cables and confirmed they work. Daisy chaining, however, does not work. Since the cables are a-okay, it's a problem in the enclosure itself. So not only can it not show up, it's not transferring the signal from my other (working) drive to my iMac.

    When I turn the enclosure on, it flashes red on each side as it looks for a drive, and both flash white when it finds one. After that, the fan just runs and nothing happens.

    Any ideas on what could be causing the problem?
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    Are you sure all cables are connected properly? Have you tried rebooting? SMC and PRAM reset? Connected it straight to the iMac (not daisy-chaining)

    The enclosure could be defective, contact the seller
     
  3. Seo thread starter macrumors regular

    Joined:
    Jun 1, 2009
    Location:
    Cupertino, California
    #3
    Yup, checked and reconnected 'em. Rebooted a couple times, and connected it straight to my iMac. However I have not tried an SMC and PRAM reset.

    I'm in talks with the seller right now to go over and test my drives in some of their other enclosures. If that checks out, I'll get my enclosure replaced. If my drives are faulty, I'll replace my drives.

    Thanks for your help, I'll report back with any news!
     
  4. Seo thread starter macrumors regular

    Joined:
    Jun 1, 2009
    Location:
    Cupertino, California
    #4
    After many a call with their customer service in Beijing (which is very excellent btw), we've determined the problem to be a compatibility issue between the newer Firewire chip in the enclosure and WD 1002FAEX drive. This being the end of the road for this wonderful combination on paper, I'm now going for a different configuration. I'm most likely just going to swap hard drives with a Seagate drive or something else that I know works to save the hassle of finding a different enclosure (my current one is very satisfactory besides the incompatibility issue).

    So yea, a word of warning for those who want the absolute newest in products. Especially products that depend on each other to be used. They're not always compatible.
     
  5. cpurdy macrumors newbie

    Joined:
    Feb 28, 2012
    #5
    WD drives not supported!

    The Western Digital drives are not supported in the IcyDock multi-drive cages, unless they are the expensive "RE" (raid edition) versions.

    See http://www.icydock.com/goods.php?id=137:

    "Western Digital desktop edition HDD does not fully support RAID function; only RAID (Enterprise) edition HDD can fully operate with the RAID faction. Click HERE to see the detail information."

    Also, the "HERE" is here:
    http://wdc.custhelp.com/app/answers/detail/a_id/1397
     

Share This Page