iDemocracy - (Mostly) Automated Jailbreak + 3rd Party Apps on iPhone 1.1.1 (Windows)

Discussion in 'Jailbreaks and iOS Hacks' started by Drakenza, Oct 21, 2007.

  1. Drakenza macrumors newbie

    Joined:
    Oct 21, 2007
    #1
    Hello all!

    Announcing the release of iDemocracy 1.1.1, a C# application designed for Windows XP or Vista that automates all the ugly command line stuff required for an iPhone 1.1.1 Jailbreak.

    iDemocracy guides the user through the whole process and automatically takes care of Symlinking, SSH installation, Installer.app installation, SpringBoard patching, etc in a clean GUI interface. No command line skills required. The upcoming version, to be released today or tomorrow, will add preliminary activation features, and possibly someday soon iDemocracy will support sim unlocking.

    The maximum user interaction required is to downgrade the iPhone; however, iDemocracy guides the user step-by-step through the process. After the downgrade, it takes care of most of the work; all you have to do is press the buttons it tells you to and reboot the phone every now and again.

    You can grab a copy of the latest version of iDemocracy at http://code.google.com/p/idemocracy
    and you can contact me at idemocracy@gmail.com if you have any comments or suggestions.

    iDemocracy is open-source software, and is in no way supported by Apple. iDemocracy merely automates as much as possible of the jailbreaking method devised by the Dev Team, and I can't accept any credit for that. Thanks to NerveGas, Pumpkin, Edgan, drudge, dinopio and asap18 for the guide and method without which this app could not exist, as well as to Nate True for the SSHkit that is implemented in iDemocracy.

    Please download it and tell me what you think

    -- Drakenza
     
  2. SheepNutz macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Kantuckee
    #2
    I have 1.0.2 with apptap and SSH and all that, but what is symlinking? Plus I saw that you had to downgrade, so with my downgraded phone, I should be good to go?
     
  3. ajl917 macrumors 6502

    Joined:
    Oct 8, 2007
    #3
    Has anyone tried this yet? I'm so excited, but I don't really wanna brick my phone...
     
  4. ivenus macrumors member

    Joined:
    Oct 21, 2007
    #4
    i go to that site on my comp and i cant click downlode, so i went on my iphone i clicked it and i cant downlode it... um yah now what
     
  5. Drakenza thread starter macrumors newbie

    Joined:
    Oct 21, 2007
    #5
    Hey all,

    Thanks for trying iDemocracy.
    There are a couple of bugs related to springpatch and symlink removal, so if you don't want to take risks, wait until sometime tomorrow when iDemocracy 1.1.1(1.1) comes out, which will include bugfixes for all these issues and also include some preliminary support for non-AT&T sim activation using anySIM.

    Thanks again for using iDemocracy, and thanks for being patient. It is still, after all, in heavy development.

    Also, to address your questions:
    - Symlinking is the process in which you make a fake shortcut to your "/var/root/Media" folder. When you update to 1.1.1, iTunes tries to rejail your iPhone by locking this folder. However, it ends up following the shortcut to "/". This leaves the iPhone jailbroken through the upgrade, which is how you end up with a jailbroken 1.1.1
    - If you already have a 1.0.2 iPhone, you will still have to restore it once to factory settings to wipe out all the hacks and mods on it. If iTunes sees a hacked 1.0.2 iPhone, it will screw up the update to 1.1.1.
    - @ivenus: You have to visit the website on your computer's browser, and you should be prompted to download the file. I just tested it, and Apple hasn't removed the file or anything. Just paste the URL into your browser's address bar and it should ask you to download.

    -- Drakenza
     
  6. firstapple macrumors 6502a

    firstapple

    Joined:
    Sep 25, 2007
    #6
    Would like to know if anyone has tried this yet? I am a windows user (sorry), and I would like to jailbreak my phone, but as of yet there have been no easy interfaces. If anyone knows of any other safe ways to go with windows please let me know!

    BTW, I have a never been messed with 1.1.1 phone. (Was 1.0.2 when I bought it then I updated same day).
     
  7. druck macrumors newbie

    Joined:
    Oct 3, 2007
    #7
    will downgrading to 1.0.2 make me have to restore? i don't wanna lose contacts and stuff.

    edit to say it's stock 1.1.1 right now, with at&t service no previous hacks installed.
     
  8. druck macrumors newbie

    Joined:
    Oct 3, 2007
    #8
    just tried it and when i got to the end my capacity was at 300megs... oh well i'll just try it again later. something i might've messed up, when it asks me to back up from my old iphone settings, should i do that or do the 'sign up as new iphone' or whatever. you never said what to do for that part and it pops up several times.
     
  9. druck macrumors newbie

    Joined:
    Oct 3, 2007
    #9
    ok tried it again, this time i got no errors or anything, it was all going great and then the same thing happened when i get to the last step. i tried opening installer and it freezes, and itunes says i have 300 megs. aaaghhh
     
  10. Drakenza thread starter macrumors newbie

    Joined:
    Oct 21, 2007
    #10
    Hi,
    this is a known issue on some iPhones in which stuff isn't chmodded properly and the symlink doesnt get deleted.
    a fix will come out today to take care of all of this, so please wait patiently.

    Drakenza
     
  11. ivenus macrumors member

    Joined:
    Oct 21, 2007
    #11
    ok so i got to the very last step's and its like go into the instalelr and downlode the "1. Go into Installer.app and update it to the latest version (as of 20 Oct 07, 3.0b). 2. Install Community Sources, BSD Subsystem and OpenSSH." ECT. well when i tap on installer.app it lodes but with nothing and freeses and goes back to my display...and when i pluged into itunes says i had no memorys just like a little. help :confused:
     
  12. ajl917 macrumors 6502

    Joined:
    Oct 8, 2007
    #12
    Look 1 post above...
     
  13. Drakenza thread starter macrumors newbie

    Joined:
    Oct 21, 2007
    #13
    iDemocracy 1.1.1(1.1)!!

    IMPORTANT
    iDemocracy has just been updated to 1.1.
    Included are bugfixes for all the issues such as springboard patching, installer.app, removing the symlink, etc.
    Also, it now can automatically upload and delete anySIM to your iPhone for unlocking!
    All chmod problems have been fixed by including BSD subsystem as part of the installation process.
    I have tested the program on my own iPhone and it works flawlessly for me.
    Please download it and try it out!

    Drakenza
     
  14. ivenus macrumors member

    Joined:
    Oct 21, 2007
    #14
    i dwnloaded the 1.1.1(1.1). What are the steps on how to do it...do i add the files into the 1.1.1 odl dwnload or not? Bc

    looks like i need the progream thats int the 1.1.1 dwnload.

    STEPS
    1. Preparation Restore iPhone to 1.0.2; Install AppTapp; Download 1.1.1 update; Reboot.
    2. Symlink Exploit Create Symlink.
    3. Reboot iPhone Reboot.
    3. Update iPhone Update to 1.1.1 in iTunes; Reboot.
    4. Test Jailbreak iPHUC, see if filesystem can be listed.
    5. Force R-W mode putjailbreak.
    5. Reboot iPhone Reboot.
    6. AppTapp Installer SSH upload Installer.App
    7. Patch Springboard SSH upload springpatch; Run springpatch; Edit M68AP.plist
    8. Remove Symlink Delete symlink, restore original.
    9. Reboot iPhone Reboot.
    10. Complete Install BSD Subsystem, Community Sources. Re-Sync with iTunes.
     
  15. AutoArt macrumors newbie

    Joined:
    Oct 21, 2007
    #15
    I followed your steps and bypassed the activation with PAYCAY while it was downgraded to 1.0.2 (this is a brand new 1.1.1 iphone by the way, just bought it today). The only problem is when I updated back up to 1.1.1 it locked it up again and is asking for activation. How can I bypass this activation?? I got all the way to step 6 without a problem, but now I'm stuck with this activation thing. Thanks.
     
  16. ivenus macrumors member

    Joined:
    Oct 21, 2007
    #16
    srry for all the questions.

    Well i did it right but now when i go into installer.app i cant do this "1. Go into Installer.app and update it to the latest version (as of 20 Oct 07, 3.0b). 2. Install Community Sources, BSD Subsystem and OpenSSH."

    and i cant install SummerBoard or SummberBoard(old) help:confused:

    i get ERROR during install script execution
     
  17. Drakenza thread starter macrumors newbie

    Joined:
    Oct 21, 2007
    #17
    Hey everyone,
    Thanks for using iDemocracy.
    Don't worry about the steps.txt file, that's not for you, that was what I used to keep track of where I was during development. You should follow the steps on the screen.
    And for those of you having Installer.app problems, this is related to some preferences persisting through the upgrade to 1.1.1 somehow, which is strange. I've yet to figure out why this is, but for now I have posted an Installer.app Fix on the iDemocracy webpage at Google Code (check under downloads). This app will basically delete Installer.app and all its preferences and then reinstall Installer.app to fix all the problems related to permissions or updating, etc.
    If you're having problems getting Installer.app to start, or if you can't install/update/remove packages or update to Installer.app 3.0, you need this program.

    Thanks again for all the support, and thanks a lot for the donations, they really do help.

    Drakenza
     
  18. ivenus macrumors member

    Joined:
    Oct 21, 2007
    #18
    Customize doesnt work...is that normal?? i see the chicken and then goes to my home.
     
  19. Virgil-TB2 macrumors 65816

    Virgil-TB2

    Joined:
    Aug 3, 2007
    #19
    You might want to pick a more appropriate name.

    Democracy, (or the lack of it), has nothing to do with iPhones and the implication given (that Apple is fascist or whatever), is guaranteed to lose you a certain amount of potential customers and makes you sound like an idiot in the bargain.

    Why not go for the gusto and call it "iRon Paul?" :)
     
  20. Drakenza thread starter macrumors newbie

    Joined:
    Oct 21, 2007
    #20
    @Virgil-TB2: :D I was going for the Apple and Apple Hacker communities to be allowed to make their own decisions on whether or not they should have third-party stuff... And the fact that democracy is "freedom" from oppressive government. Plus it stands out...
     
  21. AutoArt macrumors newbie

    Joined:
    Oct 21, 2007
    #21
    After lots and lots of research I finally figured out how to get passed the activation. I now have a fully functionaly 1.1.1 phone! Thank you very much!! I will be donating to you very soon, your program is awesome!!
     
  22. druck macrumors newbie

    Joined:
    Oct 3, 2007
    #22
    cool, thanks for the updated version. i will give it a shot when i wake up in the morning and i'll let you know how it goes.
     
  23. ohho macrumors newbie

    ohho

    Joined:
    Oct 23, 2007
    #23
    I have a newly purchased version 1.0.2 iPhone, does iDemocracy 1.1.1 work on it? Or, should I upgrade my 1.0.2 iPhone to 1.1.1 before running iDemocracy 1.1.1?

    Thanks!
     
  24. DittoMuch macrumors newbie

    Joined:
    Oct 23, 2007
    #24
    what was the issue / solution?
     
  25. AutoArt macrumors newbie

    Joined:
    Oct 21, 2007
    #25
    iDemocracy jailbreaks and unlocks the phone but doesn't bypass the activation screen. I tried a number of different ways on how to do this but wasn't able to do it. Finally after lots of research I found this
    http://modmyiphone.com/forums/showthread.php?t=11511
    but then ran into another problem. Whenever I would try to connect from WinSCP I would get a error exit 127 message (or something along the lines of that). Then I did a lot more research and figured out that for some people (not a lot) the SFTP in the protocol section needs to be changed to something else. I changed mine to SCP and it finally connected and I was able to upload the lockdown file and get past the activation screen. Then I continued on with iDemocracy and unlocked it.

    The other problem I had was with apptapp. When in 1.0.2 mode I installed apptapp but the community source files were nowhere to be found. So I updated apptapp to 1.1.1 and downloaded all the needed files. When I updated the phone to 1.1.1 it somehow downgraded apptapp to the older version but didn't know that it was the older version (meaning I couldn't updated to 1.1.1, it was stuck in the older version). It wasn't working right so I went in and deleted all the installer files through WinSCP, after that it wouldn't install apptapp anymore so I had to install it manually. I found this
    http://www.iphonealley.com/news/iphone-v1-1-1-jailbreak-apptapp-installation-guide
    and installed it that way. After that I updated apptapp and now its working with no problems.
     

Share This Page