IDLE problem

Discussion in 'Mac Programming' started by ekenne, Mar 9, 2009.

  1. ekenne macrumors newbie

    Mar 9, 2009
    I've got a problem with Python and the IDLE app.
    Everything worked fine until I changed a keyboard shortcut (I think I added a new shortcut for "run-module" with command F5). The next time I tried to run IDLE it wouldn't start at all. It just jumps like it's going to open and then disappears.
    I deleted IDLE and downloaded it again, but I still the same problem.
    I really need help with this, anyone have any clue what I should do? :confused:

  2. MacRumors Guy macrumors member

    Sep 17, 2008
    Open the Console, and then IDLE. Check if the log has any error message.
  3. wrldwzrd89 macrumors G5


    Jun 6, 2003
    Solon, OH

    The problem is almost certainly IDLE's preference file is corrupt. A redownload won't fix this, but moving/deleting the offending file will. All your preferences are in your home folder -> Library -> Preferences. Look in there for a file with IDLE or idle in its name.
  4. ekenne thread starter macrumors newbie

    Mar 9, 2009
    Thank you for the help,
    I found the idle.plist file and deleted it, but it's still the same problem. What to do?
  5. MacRumors Guy macrumors member

    Sep 17, 2008
    cd ~
    ls -al
    /* check if you have a .idlerc folder*/
    /* remove the folder */

Share This Page