iDVD not working

Discussion in 'Mac Apps and Mac App Store' started by dstearns96, Nov 14, 2008.

  1. dstearns96 macrumors member

    dstearns96

    Joined:
    Dec 16, 2007
    #1
    Ok, so I start iDVD and it gives the menu as usual, I click new project, name the project and click create, then it stops responding and gives me the spinning rainbow ball

    Oh, and in console it tells me
    Code:
    2008-11-14 21:40:11.594 iDVD[4086] *** <QCNodeManager | namespace = "com.apple.QuartzComposer" | 270 nodes>: Patch with name "OLQCTopLayer" is missing
    2008-11-14 21:40:11.594 iDVD[4086] COULD NOT CREATE STACK
    2008-11-14 21:40:11.594 iDVD[4086] *** <QCNodeManager | namespace = "com.apple.QuartzComposer" | 270 nodes>: Patch with name "OLQCLayer" is missing
    2008-11-14 21:40:11.594 iDVD[4086] COULD NOT CREATE PATCH FOR LAYER
    2008-11-14 21:40:11.595 iDVD[4086] *** <QCNodeManager | namespace = "com.apple.QuartzComposer" | 270 nodes>: Patch with name "OLQCLayer" is missing
    2008-11-14 21:40:11.595 iDVD[4086] COULD NOT CREATE PATCH FOR LAYER
    2008-11-14 21:40:11.595 iDVD[4086] *** <QCNodeManager | namespace = "com.apple.QuartzComposer" | 270 nodes>: Patch with name "OLQCLayer" is missing
    2008-11-14 21:40:11.595 iDVD[4086] COULD NOT CREATE PATCH FOR LAYER
    2008-11-14 21:40:11.599 iDVD[4086] *** <QCNodeManager | namespace = "com.apple.QuartzComposer" | 270 nodes>: Patch with name "OLQCClickableSprite" is missing
    2008-11-14 21:40:11.599 iDVD[4086] *** Message from <QCPatch = 0x1085E080 "(null)">:
    Cannot create node of class "OLQCClickableSprite" and identifier "(null)"
    2008-11-14 21:40:11.599 iDVD[4086] *** <QCNodeManager | namespace = "com.apple.QuartzComposer" | 270 nodes>: Patch with name "OLQCAspectRatioProvider" is missing
    2008-11-14 21:40:11.599 iDVD[4086] *** Message from <QCPatch = 0x1085E080 "(null)">:
    Cannot create node of class "OLQCAspectRatioProvider" and identifier "(null)"
    2008-11-14 21:40:11.599 iDVD[4086] *** Message from <QCPatch = 0x1085E080 "(null)">:
    Cannot create connection from ["outputTwoOverAspectRatio" @ "OLQCAspectRatioProvider_1"] to ["inputHeight" @ "OLQCClickableSprite_1"]
    2008-11-14 21:40:11.599 iDVD[4086] *** Message from <QCPatch = 0x1085E080 "(null)">:
    Cannot publish input port ["inputImage" @ "OLQCClickableSprite_1"]
    2008-11-14 21:40:11.599 iDVD[4086] *** State restoration failed on <QCPatch = 0x1085E080 "(null)">
    An exception of type NSGenericException occured.
    -[QCRenderInImage _uniqueKeyFromNode:]: Argument "node" cannot be null
    Stack trace:
         1	_GFThrowException (in QuartzComposer)
         2	-[GFGraph(Private) _uniqueKeyFromNode:] (in QuartzComposer)
         3	-[QCPatch(Override) addNode:forKey:] (in QuartzComposer)
         4	-[QCPatch(Wrappers) addSubpatch:] (in QuartzComposer)
         5	OLLayer::Wrap() (in OxygeneLayers)
         6	OLLayer::SetSubLayerFilter(__CFURL const*, __CFDictionary const*, OLTimeMode) (in OxygeneLayers)
         7	_OLLayer_SetSubLayerFilter (in OxygeneLayers)
         8	0x0006f06b (in iDVD)
         9	0x0006abcc (in iDVD)
        10	-[NSSet makeObjectsPerformSelector:] (in Foundation)
        11	-[NSIBObjectData nibInstantiateWithOwner:topLevelObjects:] (in AppKit)
        12	_loadNib (in AppKit)
        13	+[NSBundle(NSNibLoading) _loadNibFile:nameTable:withZone:ownerBundle:] (in AppKit)
        14	+[NSBundle(NSNibLoading) loadNibFile:externalNameTable:withZone:] (in AppKit)
        15	+[NSBundle(NSNibLoading) loadNibNamed:owner:] (in AppKit)
        16	0x0000605d (in iDVD)
        17	0x000e29cf (in iDVD)
        18	0x000e3bb5 (in iDVD)
        19	0x000de373 (in iDVD)
        20	0x00026b1b (in iDVD)
        21	0x000e39d3 (in iDVD)
        22	__nsnote_callback (in Foundation)
        23	___CFXNotificationPost (in CoreFoundation)
        24	__CFXNotificationPostNotification (in CoreFoundation)
        25	-[NSNotificationCenter postNotificationName:object:userInfo:] (in Foundation)
        26	-[NSNotificationCenter postNotificationName:object:] (in Foundation)
        27	-[NSApplication _postDidFinishNotification] (in AppKit)
        28	-[NSApplication _sendFinishLaunchingNotification] (in AppKit)
        29	-[NSApplication(NSAppleEventHandling) _handleAEOpen:] (in AppKit)
        30	-[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] (in AppKit)
        31	-[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] (in Foundation)
        32	__NSAppleEventManagerGenericHandler (in Foundation)
        33	aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned long, unsigned char*) (in AE)
        34	dispatchEventAndSendReply(AEDesc const*, AEDesc*) (in AE)
        35	_aeProcessAppleEvent (in AE)
        36	_AEProcessAppleEvent (in HIToolbox)
        37	__DPSNextEvent (in AppKit)
        38	-[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] (in AppKit)
        39	-[NSApplication run] (in AppKit)
        40	_NSApplicationMain (in AppKit)
        41	0x00003ed9 (in iDVD)
        42	0x0000362a (in iDVD)
    2008-11-14 21:40:11.844 iDVD[4086] NSExceptionHandler has recorded the following exception:
    NSGenericException -- -[QCRenderInImage _uniqueKeyFromNode:]: Argument "node" cannot be null
    Stack trace:  0x96039243  0x01b4f0b3  0x01b50cf1  0x01b36ad2  0x01ab91f3  0x01b36a84  0x003b5224  0x003b54ff  0x003b16fe  0x0006f06b  0x0006abcc  0x927f26a0  0x93278172  0x9326f479  0x9326eea9  0x9326eb0a  0x9326ea4c  0x0000605d  0x000e29cf  0x000e3bb5  0x000de373  0x00026b1b  0x000e39d3  0x927f2237  0x908553d2  0x9084cb51  0x927ea7c8  0x927f1769  0x93283976  0x93283860  0x9328335d  0x93282f28  0x927f7f21  0x927f7d4b  0x915226c5  0x915225f6  0x915224c2  0x92dfb084  0x9328111d  0x93280b37  0x9327a8c4  0x9326e820  0x00003ed9  0x0000362a  0x00003551  0x00000002
    2008-11-14 21:40:11.844 iDVD[4086] Exception raised during posting of notification.  Ignored.  exception: -[QCRenderInImage _uniqueKeyFromNode:]: Argument "node" cannot be null
    

    and when I force quit it it tells me

    Code:
    ##**## Not encoding -> exit(5)
    
     
  2. EricNau Moderator emeritus

    EricNau

    Joined:
    Apr 27, 2005
    Location:
    San Francisco, CA
    #2
    Have you tried restarting? Sometimes it's amazing what a simple restart can accomplish.
     
  3. dstearns96 thread starter macrumors member

    dstearns96

    Joined:
    Dec 16, 2007
    #3
    Didn't work
     
  4. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #4
    Reinstall iDVD from your restore DVDs, it looks like some files got corrupted or accidentally deleted.
     

Share This Page