If you have a Bootcamp Partition, read this thread

Discussion in 'iMac' started by ks-man, Apr 25, 2011.

  1. ks-man macrumors 6502a

    Joined:
    Sep 25, 2007
    #1
    I was getting very poor performance on my iMac for some time but never gave it all that much thought. Recently though it was getting smoked by my MBA. I did some searching and found that the problem was related to my Bootcamp partition. I guess Spotlight tries to index bootcamp but because of the NTFS drive it causes a bottleneck. I use WinXP but I read about other people having issues with Vista and 7.

    Here is what I did:
    1) Create a blank Notepad txt document at the root level of your c: drive called .metadata_never_index.txt
    2) Run CMD
    3) ren c:\.metadata_never_index.txt .metadata_never_index
    4) Restart Windows
    5) Restart Mac OS

    The idea is to create a file at the root level called .metadata_never_index
    You need to use the rename function in CMD to remove the .txt. Having this file on your c: drive will tell Spotlight to ignore Bootcamp.

    This drastically has sped up the performance of my Mac OS. Many applications would take between 4-20 bounces of the App before they opened. Now most open on the first and the worst offender (Chrome) is usually 3-4. Switching between Spaces is much quicker also. Startup on Windows is faster as well.

    Hope this helps other people. I don't know if everybody is having this problem or just certain people. I think my problem may have started when I upgraded from Leopard to Snow Leopard so if you do or don't notice improvements with this fix be sure to mention what your original and current OS versions are.
     
  2. ShiftyGray macrumors regular

    Joined:
    May 19, 2010
    #2
    What about Systems Preferences -> Spotlight -> Privacy and add the partition and folders you don't want indexed?
     
  3. ks-man thread starter macrumors 6502a

    Joined:
    Sep 25, 2007
    #3
    I read somebody reporting that they still had issues doing it that way but had success after creating the file themselves. I would think it would do the same thing but who knows. I guess the main point should be ensuring the Spotlight isn't indexing the Bootcamp drive as I'm pretty confident that is where the bottleneck is.
     
  4. ShiftyGray macrumors regular

    Joined:
    May 19, 2010
    #4
    I am too, and I had the same issue before. This is how I solved it.
     
  5. ks-man thread starter macrumors 6502a

    Joined:
    Sep 25, 2007
    #5
    After reading over this webpage and one of the responses it seems like the above method may not actually work. Here is the response:

    I think the method of actually creating the file in the Bootcamp partition is a better method. The webpage linked above shows another way to create the file with nice graphical support.

    Hope it helps.
     
  6. ShiftyGray macrumors regular

    Joined:
    May 19, 2010
    #6
    Then how do you explain it does work for me? It does save it upon restart. And it also makes no sense to say it doesn't save on an NTSF disk, because I would guess the settings are saved on the Mac partition.
     
  7. Sunday Ironfoot macrumors regular

    Joined:
    Apr 14, 2011
    #7
    Thanks, for the tip. I'll be using bootcamp when I get my iMac, so this will definitely come in handy.

    Not sure why you'd need CMD, you can just remove the file extension in Windows Explorer.

    Also, why doesn't bootcamp do this anyway if it causes such a huge problem with OSX?
     
  8. ShiftyGray macrumors regular

    Joined:
    May 19, 2010
    #8
    Okay, I think I now why it does work for me. I have made my NTFS partition writable using some software, hence that my suggestion at the beginning does work.
     
  9. theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #9
    It's also worth noting that if you use a Time Machine backup, make sure that you set up Spotlight to exclude it from indexing.
     

Share This Page