If Your Screen Sharing Stops Working, Read This

Discussion in 'macOS' started by clayj, Feb 24, 2008.

  1. clayj macrumors 604

    clayj

    Joined:
    Jan 14, 2005
    Location:
    visiting from downstream
    #1
    SCENARIO: I have a network of Macs. On my main machine (a mac pro), I have set up bookmarks in Safari that link to the Screen Sharing URLs for other Macs on my network (Mac minis, MacBook Air). For example:

    vnc://192.168.1.51
    vnc://192.168.1.52

    So I can kick off a Screen Sharing session with one of those Macs simply by clicking the appropriate bookmark in Safari.

    PROBLEM: Sometimes when I do this, one of two things happens... either the Screen Sharing program launches in the dock but the window for the other Mac does not appear at all, or the Screen Sharing program launches and a small black window (with nothing visible inside) appears. Killing and restarting Screen Sharing does not help, and restarting the remote Mac does not help.

    SOLUTION: One way to solve this problem is to restart the Mac where you are attempting to use Screen Sharing. But this is overkill; it works because it incorporates the second, easier solution to the problem:

    1. Launch the Activity Monitor program.
    2. In the Process Name list, look for "NetAuthAgent". It may show as "Not Responding".
    3. Select NetAuthAgent, and then click Quit Process (the red stop sign button at the top of the Activity Monitor window). Then, click Force Quit.

    Your Screen Sharing should now work.

    It appears that as part of connecting to the remote Mac, your Mac must authenticate itself... and NetAuthAgent is part of this process. If this program freezes, hangs, or locks for any reason, the authentication will not work, and you cannot use Screen Sharing. Killing NetAuthAgent is harmless, as far as I can tell, and it will automatically relaunch the next time it is needed.

    For anyone else having problems with Screen Sharing not working correctly, I hope this information helps.
     
  2. AppleFan360 macrumors 68020

    Joined:
    Jan 26, 2008
    #2
    I have had this happen. Thanks for the heads up. Very informative post.
     
  3. deboni macrumors member

    deboni

    Joined:
    Jun 9, 2007
    Location:
    Oakland, CA
    #3
    NetAuthAgent bug

    Please report this scenario to Apple. It sounds like something buggy that they could (and should want to) easily correct, given you precise replication description.

    Tom
     
  4. mike.jalkut macrumors newbie

    Joined:
    May 19, 2008
    #4
    You get the life saver of the year award. I about broke my head, banging it against the wall, on this one. Right on the money. Thanks!
     
  5. marclevoy macrumors newbie

    Joined:
    May 19, 2008
    #5
    Screen sharing

    Works for me too. You nailed it. Thanks!

    -Marc Levoy
    Stanford University
     
  6. rsande macrumors newbie

    Joined:
    Mar 6, 2008
    #6
    Thanks for this. Wish I had relied on the Wisdom of the Net before rebooting the remote computer... Oh well.
     
  7. nsayer macrumors 6502a

    nsayer

    Joined:
    Jan 23, 2003
    #7
    I'm having problems connecting to one of the hosts on my network, and this doesn't help.
     
  8. clayj thread starter macrumors 604

    clayj

    Joined:
    Jan 14, 2005
    Location:
    visiting from downstream
    #8
    Is your NetAuthAgent "Not Responding" when the problem occurs?

    FWIW, this problem still occurs in the very latest Mac OS X 10.5.5.
     
  9. stukdog macrumors 6502

    Joined:
    Oct 20, 2004
    #9
  10. iGrant macrumors 6502a

    iGrant

    Joined:
    Sep 20, 2006
    Location:
    Abingdon
    #10
    Agreed thanks for the information. I live in Screen Sharing I feel like. I was the only feature in 10.5 at the time I was looking forward to :cool:. I have been wondering on what would case this to happen and what a solution would be.

    Ditto on sending this information to Apple. Screen Sharing is a new Core Service that was introduced into Leopard. I consider it Apple Remote Desktop Lite Edition. This is a bug that could be probably catch and corrected easily.

    Love ARD but I only used it for the basics, never the extra feature that came with it, so when I saw Screen Sharing was going to be apart of 10.5 I was really excited.

    For the most part is has done everything I wanted, but the freezing was extremely annoying.

    -iGrant
     
  11. kpdsgt7 macrumors newbie

    Joined:
    Sep 11, 2009
    #11
    Share Screen Mac osx 10.6

    I have been reading all your posts. First let me say, I am new to mac. I have had a problem with share screen from my mac book to my mac pro. I read al the posts and no matter what I did, i could not control the mac pro from the mac book. Called apple and nothing there. Really smart guy but could not fix. I finally figured it out by myself. windows style. I had VNC server running and I had to uninstall. boom. It worked both ways.

    So. if all else fails and you spend days and days reading the forums and can't fix it. remove the server part of the vnc. In my case I uninstalled all. I got it and it works sweet. Wish I went mac years ago. see ya
     
  12. lilgto64 macrumors member

    Joined:
    Apr 13, 2009
    Location:
    Ohio
    #12
    Sweet - thanks

    Thanks - that one has been bugging me for some time - my NetAuthAgent did not show as not responding but it still worked - did not even affect an open screen sharing session - just got rid of the modeless dialog that I could not previously associate with any particular process.
     
  13. ecapdeville macrumors member

    ecapdeville

    Joined:
    Nov 22, 2005
    Location:
    Mexico City
    #13
    Hello...

    I have a completely different problem but it affects screen sharing...

    I have a Powermac G4 which is used as a file and printer server with OSX 10.4.11... this machine is connected to other 3 Macs running in OSX 10.6.3.

    I could share files without problem, I just need to write the login and password of the server and it works...except screen sharing, it wont recognize the login or the password. The option of share screen is turned on at the G4 in fact almost everything in the share section is turned on (except internet sharing)...

    The other macs can see the G4, can get into files and can print...but wont share screen and I need it because this G4 doesnt have a monitor and is 24hrs turned on.

    thank you for your help.
     
  14. svenwillmann macrumors member

    Joined:
    May 6, 2008
    #14
    Thanks for the post, very useful information

    In addition I had the problem not being able to log in to the remote machine, solved it this way

    Hope it helps someone as well
     
  15. rock-adventures macrumors newbie

    Joined:
    Jun 3, 2010
    #15
    Hot sure the NetAuthAgent bit is any use or not; I have no such process running!?

    However, the idea of having vnc:// links in your Safari bookmarks list is genius! :)
     
  16. BluesBrother macrumors newbie

    Joined:
    Feb 7, 2011
    #16
    Try Chicken of the VNC as an Alternative

    I've encountered this same problem (Snow Leopard hangs when trying to connect via VNC). Being able to quit NetAuthAgent and try again is a god-send.

    However, as an alternative to this annoying problem, I've starting using ChickenOfTheVNC. I don't like it quite as much as the Mac's built-in VNC support, but at least it connects! :)

    Maybe Apple will finally get around to fixing this problem -- some day!
     
  17. windowpain macrumors 6502a

    Joined:
    Apr 19, 2008
    Location:
    Japan
    #17
    Wow, thanks for the information.
    I was getting sick of having to reboot every time the screen sharing app decided to hang. A much better solution.

    And the bookmarked links idea is great. Many thanks. :)
     
  18. clayj thread starter macrumors 604

    clayj

    Joined:
    Jan 14, 2005
    Location:
    visiting from downstream
  19. Juan Enrique macrumors newbie

    Joined:
    Jun 25, 2011
  20. onewheelskyward macrumors newbie

    Joined:
    Oct 26, 2011
    #20
    Lion Update

    Thanks for the clue! I had this issue with Lion this am, and while I didn't find a task called NetAuthAgent, I did have a NetAuthSysAgent running. It wasn't listed as not responding, but when I killed it my Screen Sharing was able to produce a connection, thus saving me effort of rebooting my machine.

    So, for you 10.7 folks, kill NetAuthSysAgent.
     
  21. lilgto64 macrumors member

    Joined:
    Apr 13, 2009
    Location:
    Ohio
    #21
    Sometimes

    Sometimes that helps and sometimes that does not.

    Just a moment ago - after connecting numerous times to various systems on my network - screen sharing stopped working properly.

    I clicked Share Screen - the connecting dialog popped put he disappeared - and the authentication window never appeared - and no remote window appears.

    I Quit Screen Sharing and it says there are open connections - but there is no way to see them.

    I did the force quit of both NetAuthAgent and NetAuthSysAgent - no luck.

    Also did a logout - login - no luck.

    Full reboot fixed it - so not sure if there is another way either in the Activity Monitor or maybe via the terminal - DNS flush or something perhaps - but there is something not entirely 100% with screen sharing.

    I also use other products such as LogMeIn and TeamViewer and Timbuktu - so that I can still get into systems when I need to (don't necessarily have all of those on every remote system - but better to have more than only one way to access a remote system).
     
  22. JLMstriker8 macrumors newbie

    Joined:
    Mar 10, 2012
    #22
    I'm assuming the NetAuthAgent process that's hanging is on the client end?
    Is there any way to do this remotely? I'm about 500 miles from my client machine at the moment so physically rebooting it is not an option.
    I've tried telnet as well but it will not authenticate (most likely due to the NetAuthAgent, as I've now learned).

    Is there any other way to reboot the machine remotely?
     
  23. Sitckybeak macrumors newbie

    Sitckybeak

    Joined:
    Jun 10, 2012
    Location:
    Sydney, Australia
    #23
    Grrrrrrrr

    I have tried each of the suggestions in this thread to no avail.
    This problem has only recently started with me - I had been using screen sharing without issues for 18 months to 2 years.
    Any insights into why this would be and/or possible solution gratefully received!
     
  24. pkiula macrumors member

    Joined:
    Mar 29, 2008
    #24
    Me too. Just started last week. Connecting from Macbook Air to Macbook Mini. Rebooting and the silly suggestions at the beginning of the thread don't work. Any other ideas?
     
  25. sweetrats macrumors newbie

    Joined:
    Aug 9, 2012
    #25
    Me three

    I just started having this problem today. I use a VPN then VNC to my work computer. I have been connecting like this without problem for years.

    Screen Sharing opens and appear like its trying to connect, but just sits like that. Normally, when it can't connect I get a message saying so. Nothing.
    I did try all the fixes above, rebooting, checking the activity monitor for NetAuthAgent - not there.

    I can AFP and SSH no problem. But, I have a ton of work to do and really need to see my screen.

    :mad:
     

Share This Page