iPhone Ifaith causing error code -1 in itunes during restore

Discussion in 'Jailbreaks and iOS Hacks' started by idontjailbreak, Feb 23, 2013.

  1. idontjailbreak macrumors newbie

    Joined:
    Feb 23, 2013
    #1
    Hey All,


    I have an issue whose resolution was to use IOS 4.1.

    I had 5.1.1, which I jailbroke on abscinthe, and used the "dump SHSH" in Ifaith (wanted to use tiny umbrella, but it wouldnt pick up the 5.1.1 shsh, only the 6.1.2 and 4.1). The file was saved with the ECID in the file name. I thought all was well, so If I downgrade, I could easily upgrade back to 5.1.1 by creating a stitched version of the original ipsw.

    So i sucesfully downgraded to 4.1.1. However I wanted to see if I could upgrade easily. So I opened Ifaith, built a IPSW with the saved SHSH from the Ifaith dump. It created the IPSW, i used the PWND DFU mode, went into ITUNES and selected the IPSW that IFaith had created. It recognizes the ipsw, it begins restoring, and then I see the Ifaith logo where the apple logo should be (as the online tutorial says it should). However at the very end of the restore, Itunes throws error code -1, and states Iphone could not be restored.

    This begins the cycle of keeping my screen stuck on the "connect itunes logo". I try to enter DFU, doesnt work just restarts. I try Tinyumbrella, it has a number identification which changes, every time I click exit recovery. the Log file shows exit query submitted, then null. FInally I download ireb 6.0 nd finally get it out, and back into pwned DFU mode. I install 4.1.1, and Im back to normal.

    Im wondering did Ifaith not save the ShSH blobs, or am I doing something incorrect.

    My modem version is stationary at 5.16.05 (I had this when I was in 5.1.1, and 4.1.1).

    Ifaith 1.5.3
    Latest Redsnow
    Latest Tiny Umbrella
    Latest Abscinthe

    dct download of stock ipsw from redmond pie.
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    With everything you typed, I have no idea what you need to do with your phone (you say you want to see if you could do this and that).

    If you need to preserve baseband for unlocking, use Sn0wbreeze to do a No BB restore to iOS6
    If you don't need to preserve baseband, then use iTunes, punch the restore button.
     
  3. idontjailbreak thread starter macrumors newbie

    Joined:
    Feb 23, 2013
    #3
    The main purpose is to return to IOS 5.1.1 from IOS 4.1.1 (which am I currently am on).

    History:

    I was on 5.1.1, jailbroke, saved SHSH on 5.1.1 using iFaith.
    Downgraded 5.1.1 to 4.1.1. Worked beautifully.
    Then I decided to upgrade to 5.1.1 again.

    I stitched the firmware with the save SHSH blobs using Ifaith, and a stock IPSW for 5.1.1.

    Using the pwnd DFU mode, I went into itunes, tried restoring, which it does, but then at the end, Itunes shows me error code -1.


    So in all, IM trying to go back to 5.1.1 with the SHSH blobs i saved in Ifaith, but everytime i get error code -1.
     
  4. idontjailbreak thread starter macrumors newbie

    Joined:
    Feb 23, 2013
    #4
    Situation Resolved.

    After toying around and around and around, I found a better tutorial on I download, and got out of the recovery looop, into normal DFU then used the recovery fix on Redsnow. Worked Like a charm.

    Thanks!


    NOTES:
    Itunes Error -1, may indicate a hardware issue or BB issue.
    IN my case never messed with BB, and the hardware works with 4.1.

    I finally got into DFU and used the recovery fix from Redsn0w and back to stock 5.1.1
     
  5. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #5
    Glad it worked out

    The -1 error code indicates the restore could not finish because the baseband portion of the restore (which takes place after the firmware restore) was interrupted (by design on a No BB restore). This leaves the device in recovery mode.
     

Share This Page