ifconfig: ioctl(SIOCGIFAFLAG_IN6): Can't assign requested address

Discussion in 'OS X Mountain Lion (10.8)' started by hrsahu, Jul 18, 2014.

  1. hrsahu macrumors newbie

    Joined:
    Jul 18, 2014
    #1
    Hi All,
    I was trying to add a IPv6 address to the Ifconfig en0 interface
    Code:
    sudo ifconfig en0 inet6 fe80::204:a3ff:fe12:13b4 add
    
    command was successful

    but when i do
    ifconfig en0

    this the following result

    Code:
    flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
     * *options=2b<RXCSUM,TXCSUM,VLAN_HWTAGGING,TSO4>
     * *ether 40:6c:8f:05:5d:f0 
     * *inet6 fe80::426c:8fff:fe05:5df0%en0 prefixlen 64 scopeid 0x4 
    i[COLOR="Red"]fconfig: ioctl(SIOCGIFAFLAG_IN6): Can't assign requested address[/COLOR]
     * *inet 169.254.137.225 netmask 0xffff0000 broadcast 169.254.255.255
     * *media: autoselect (100baseTX <full-duplex,flow-control>)
     * *status: active
    
    I can't get the configured Ipv6 link local address

    could you please help me on this .. and it very urgent?
    I am trying to use OS X as the IPv6 host and for IPv6 certification , Link local address should be added .
     
  2. hrsahu thread starter macrumors newbie

    Joined:
    Jul 18, 2014
    #2
    Hi All,
    Any reply on this issue.
    If there is any other solution for this issue, please provide.
     
  3. hrsahu thread starter macrumors newbie

    Joined:
    Jul 18, 2014
    #3
    Hi All,
    I did this following command to add a Ipv6 link local address to the interface en0

    Code:
    networksetup -setv6manual Ethernet fe80::204:a3ff:fe12:13b4 64 fe80::21f:d0ff:fe40:8bbd
    
    but the observation is -
    ifconfig doesn't show any IPv6 link address

    Code:
    
    $ ifconfig en0
    en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    	options=2b<RXCSUM,TXCSUM,VLAN_HWTAGGING,TSO4>
    	ether 40:6c:8f:05:5d:f0 
    	inet 169.254.138.147 netmask 0xffff0000 broadcast 169.254.255.255
    	media: autoselect (100baseTX <full-duplex>)
    	status: active
    
    
    Please provide your input
     
  4. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #4
    Well according to the maul page :

    Code:
    setv6off networkservice] [-setv6automatic networkservice] [-setv6manual network service address prefixLength router]
    See if you change you networksetup using the set6manual string.
     

Share This Page