Ignore Trackpad When Mouse Is Present

Discussion in 'MacBook Pro' started by RaceJunkie, Nov 7, 2008.

  1. RaceJunkie macrumors regular

    Joined:
    Dec 18, 2007
    Location:
    North Carolina
    #1
    I just upgraded from a MacBook to a MBP and on the MB there was a feature that I could turn off the track pad when a mouse was present. I don't see this anymore was it removed?
     
  2. andrewdale macrumors 6502a

    Joined:
    Jan 28, 2008
    Location:
    Memphis, TN
    #2
    I'm not sure what model you have, but I have an early 2008, and it's still there.

    System Preferences>Keyboard&Mouse>Trackpad at the bottom
     
  3. RaceJunkie thread starter macrumors regular

    Joined:
    Dec 18, 2007
    Location:
    North Carolina
    #3
    Brand New MBP Alum


    Model Name: MacBook Pro
    Model Identifier: MacBookPro5,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.53 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 6 MB
    Memory: 4 GB
     
  4. Balty macrumors 6502

    Balty

    Joined:
    Jun 12, 2008
    Location:
    Canberra, Australia
    #4
    I've got it on my early 2008 too.....
    (Click to enlarge)
    Ignore mouse.png


    Check in both your Keyboard & Mouse and Trackpad preferences or type it into System Pref's search.....
    When you type "turn off trackpad" in there on mine it comes up with the area where the option is.

    It also says I don't have a trackpad installed on my computer!?!? :confused: :eek:
    Picture 3.png
     
  5. RaceJunkie thread starter macrumors regular

    Joined:
    Dec 18, 2007
    Location:
    North Carolina
    #5
    The new MB has it's own track pad settings.
     

    Attached Files:

  6. RaceJunkie thread starter macrumors regular

    Joined:
    Dec 18, 2007
    Location:
    North Carolina
    #6
  7. mknawabi macrumors 6502

    mknawabi

    Joined:
    Feb 5, 2006
    Location:
    Irvine, CA
    #7
    command+space -> type in terminal -> click the terminal icon -> type "defaults write -g com.apple.mouse.ignoreTrackpadIfMousePresent 0" without the quotes

    get an error message?
     
  8. RaceJunkie thread starter macrumors regular

    Joined:
    Dec 18, 2007
    Location:
    North Carolina
    #8
    Yea that's what I done, except I c/p it then hit return, closed everything logged off then back on. Still track pad works. I am using a Logitech blue tooth mouse, I wonder if this works only with a usb mouse?
     
  9. powersurge macrumors member

    Joined:
    Apr 30, 2008
    Location:
    Pensacola, FL
    #9
    As good as the trackpad is on the new Macbook Pro its still a trackpad. I really wish there was an option to turn mine off when I plug in my wireless mouse. I keep bumping the trackpad when I'm typing which is really annoying. :(
     
  10. RaceJunkie thread starter macrumors regular

    Joined:
    Dec 18, 2007
    Location:
    North Carolina
    #10
    Yea me too. I don't know what Apple was thinking with removing this option.
     
  11. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #11
    You must type in an odd manner, it never happens to me.
     
  12. tkjune macrumors newbie

    Joined:
    Nov 12, 2008
    #12
    Hello RaceJunkie,

    I think you should use this command
    defaults write -g com.apple.mouse.ignoreTrackpadIfMousePresent 1
    pls note that the number is 1, not 0
    I'm using Logitech bluetooth mouse too.
    I think there's no difference between mbp you use and mb i use on this issue.

    Good luck
     
  13. Red-red macrumors 6502

    Joined:
    Jul 17, 2007
    #13
    What I was thinking and when I do the only bit that touches it is the bottom of my hand and it doesn't register anyway.
     
  14. RaceJunkie thread starter macrumors regular

    Joined:
    Dec 18, 2007
    Location:
    North Carolina
    #14
    Thanks but this still does not work for me..
     

Share This Page