iJailbreak 0.5.3 and The Virginizer on a 1.0.2 iPhone

Discussion in 'Jailbreaks and iOS Hacks' started by mandalay, Feb 14, 2008.

  1. mandalay macrumors newbie

    Joined:
    Feb 14, 2008
    #1
    I had an early iPhone running on FW 1.0.2 and hesitated ever since to upgrade to the flavor of the day.

    With 'The Virginizer' from i.unlock.no (http://iphone.unlock.no/#already-unlocked-virginize) and the new ijailbreak 0.5.3 out I finally gave it a shot ...
    and was not disappointed.

    Everything worked exactly as advertised.

    1. Follow the instructions given in the link above (i.unlock.no): revirginize (baseband fix)

    2. Plug iPhone into iTunes, when asked to update to the newest firmware (1.1.3), do so. Then close iTunes
    3. Download iJailbreak 0.5.3 (notice: this version only works for Leopard on a PPC -> NO Intel, but with any iPhone: old/new, boot loader 3.9/4.6, ...), connect iPhone to cable, run iJailbreak, and YOU'RE DONE!!

    The entire process takes (including the installation of the new firmware) 40 minutes and no more than 5 clicks.
     
  2. deniser macrumors 6502

    deniser

    Joined:
    Sep 14, 2007
    Location:
    Cornwall, England
    #2
    I used ijailbreak 0.5.3 today on an intel MB running leopard and it worked
     
  3. mandalay thread starter macrumors newbie

    Joined:
    Feb 14, 2008
    #3
    DONE, meaning: you're iPhone is activated, unlocked, jailbroken and comes already installed with installer.app -> so you can start adding 3rd party apps right away using WiFi.

    PS: You're current provider SIM card can stay in the phone during the entire process. no need for that pre-packaged ATT card.
     
  4. Elimo macrumors newbie

    Joined:
    Feb 14, 2008
    Location:
    Singapore
    #4
    Need to re-virginize on jailbroken 1.1.1 iPhone?

    My iPhone is a 41 week running on 1.1.1 so do I need to revirginize (or I can still run it with no harm) before running iJailbreak?:confused:
     
  5. themanfromvlad macrumors 6502

    themanfromvlad

    Joined:
    Mar 11, 2006
    Location:
    Montreal
    #5
    Thanks mandalay, your post made me bite the bullet and finally upgrade. Only snafu was that I couldn't restore my phone to 1.1.3 with iTunes on my Leopard partition. I had to virginize, restart in Tiger, restore, then use iJailbreak in Leopard.

    I suspect this might be because i have iTunes 7.4.2 in Leopard and 7.6 in Tiger. Oh well, it worked and I'm so happy.
     
  6. mandalay thread starter macrumors newbie

    Joined:
    Feb 14, 2008
    #6
    to elimo:

    If you unlocked the phone running 1.1.1 you should be fine without revirginizing ... (messed up basebands only occurred with early unlock tools before the release of FW 1.1.1)

    so you can directly proceed to iJailbreak for an upgrade to 1.1.3 ...
    but make sure you're mac fulfills the requirements listed on iJailbreak.com for a secure upgrade (though some people upgrade flawlessly on intel and/or tiger machines) ...

    to themanfromvlad: glad to be of help :)
     
  7. Elimo macrumors newbie

    Joined:
    Feb 14, 2008
    Location:
    Singapore
    #7
    iJailbroken 1.1.3 from 1.1.1 upgrade

    I did it and most of the stuff from 3rd party are working, thanks for your advices.

    Only slight problem now is on the alternate SMS applications like iSMS or WeTool. They are not working. They are better than the SMS original application particularly when there are strange characters in SMS messages with kick out SMS application but in iSMS / WeTool I can identity the odd message and after deletion even SMS application worked again.:eek:
     
  8. pidge1114 macrumors newbie

    Joined:
    Jul 8, 2008
    #8
    so if I understand correctly...

    If I am running a jailbroken 1.0.2 and I want to get to 1.1.4, I shouldn't just restore the iphone. I first have to revirginize the phone, THEN restore through iTunes...and then finally update to 1.1.4 and THEN jailbreak it again?
     

Share This Page