iLife '08 will not install

Discussion in 'Mac Apps and Mac App Store' started by ExtraLife, Aug 13, 2007.

  1. ExtraLife macrumors newbie

    Joined:
    Mar 11, 2006
    Location:
    Orange County, California
    #1
    Hey guys, I'm running into a little trouble with trying install iLife '08 on my iMac PowerPC G5 (10.4.10).

    During the "Introduction" part of the installation I get an error that reads "iLife is not compiatible with the language of your computer. Please obtain a copy of iLife '08 for the language of your computer."

    The weird thing is that I installed iLife '08 perfectly on my MacBook Intel Core 2 Duo (10.4.10) with the same Installer package.

    Both of my computers are in the English language, so I have no idea what the problem could be. Is there a preference that I might have switched or changed that would be the problem?

    Any possible solution(s) will be greatly appreciated.
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Have you used an app like Monolingual to remove languages or architecture files?
     
  3. ExtraLife thread starter macrumors newbie

    Joined:
    Mar 11, 2006
    Location:
    Orange County, California
    #3
    Nope.

    From the looks of it, it looks like all that app does is just re-claim lost hard-drive space by removing unnecessary languages on your system...

    Would it even really help my problem if I did use it?
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    No, I thought it may have caused your problem. Where did you get the installer package? Is it a retail version of the DVD?
     
  5. ExtraLife thread starter macrumors newbie

    Joined:
    Mar 11, 2006
    Location:
    Orange County, California
    #5
    Yeah, it is. It's a legit copy of iLife '08.

    It's so weird how it would perfectly install on my Macbook, but not my iMac. :(
     
  6. amallett macrumors newbie

    Joined:
    Jan 28, 2008
    Location:
    Farmington, Me.
    #6
    iLife '08 installation problem too

    I can not install my iLife'08 into my OS X 10.4.11.
    Completely reinstalled everything into my computer and it looks good
    for the process until at the end after seeing the blue bar cross over into the final stage of installation and then nothing. No installation. Not on my harddrive. Not to be seen. The icon of an open box shows up. I've come full
    circle without an actual installation. Any suggestions? It looks like a the real mcCoy iLife'08 and if it wasn't, wouldn't I see the word "retail"? Anyway, no
    words that lead me to believe it is something less than what I ordered.
     

Share This Page