iLife 09 on a G5

Discussion in 'Mac Apps and Mac App Store' started by masterjedi73, Jun 11, 2009.

  1. masterjedi73 macrumors 6502

    masterjedi73

    Joined:
    Jan 12, 2004
    #1
    I was just reading over the requirements for iLife 09 and it says that iMovie will only work on a PowerMac G5 with dual 2.0 processors. Since mine is a dual 1.8, can I use the rest of iLife 09 and then use the previous version of iMovie? Right now I'm using iLife 05 and I need to upgrade....

    thanks.
     
  2. rdowns macrumors Penryn

    rdowns

    Joined:
    Jul 11, 2003
    #2
    You sure can. Choose a custom install and uncheck iMovie.
     

Share This Page