iLife '09 - Spotlight Preference Pane crashing now

Discussion in 'Mac Apps and Mac App Store' started by netnothing, Jan 26, 2009.

  1. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #1
    After installing iLife '09 today on 3 different Macs, when I try to go into Spotlight Preferences, System Preferences crashes.

    Can anyone try this if you have installed iLife '09.

    Thanks!

    -Kevin
     
  2. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
  3. netnothing thread starter macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #3
    Ok very weird.....preferences panes finally opened on all 3 machines, but now the main window on all 3 look like the attached screenshot.

    Anyone else like this? Weird that all 3 machines are doing the same thing. All machines are 10.5.6 and just had iLife '09 installed.

    -Kevin
     

    Attached Files:

  4. netnothing thread starter macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #5
    Ok, on 1 of the machines, I did the 2nd reboot after installing iLife '09.

    The typical cmd+space doesn't bring up Spotlight....probably because the screenshot I send shows no shortcut.

    -Kevin
     
  5. netnothing thread starter macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #6
    Does your screen look normal?

    How did you open the prefs.....through the spotlight dropdown, or from the main system preferences screen?

    Seems when I open through the spotlight dropdown, it opens, but when I select from the main system preferences, it doesn't.

    -Kevin
     
  6. MaskingTape macrumors regular

    Joined:
    Jan 9, 2009
    #7
    Having the same prob on my laptop and iMac.... weird.
     
  7. netnothing thread starter macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #8
    Does your screen look like mine?

    -Kevin
     
  8. MaskingTape macrumors regular

    Joined:
    Jan 9, 2009
    #9
    Yup. Plus spotlight prefs arent being saved. I have it not search emails/web pages/etc but now it still shows them in the search.
     
  9. netnothing thread starter macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #10
    I've had to wait for the 2 other machines to stop the Faces detection to try anything else. So far on 2 of the 3 machines so far:

    - Install iLife '09
    - Reboot from the install
    - After 1st reboot, spotlight keyboard shortcuts still work, but are not displayed in the spotlight prefs window
    - Forced a 2nd reboot
    - After 2nd reboot, cmd+space no longer works. Only way to get it back is to adjust the keyboard shortcuts in Keyboard & Mouse...not Spotlight.
    - At this point the key combo sticks, but still has issues with the empty items in the spotlight prefs.

    -Kevin
     
  10. netnothing thread starter macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #11
    Weird prefs in the keyboard pref pane after the 2nd reboot:

    What is Input Menu and why is it disabled with Spotlights keys?

    -Kevin
     

    Attached Files:

  11. MaskingTape macrumors regular

    Joined:
    Jan 9, 2009
    #12
    I dont have input menu. Oh well I'm sure Apple will release a fix. Ive tried deleting the spotlight plist file and that didnt solve anything. I don't want to start removing spotlight plugins just yet to see if thats a cause.
     
  12. netnothing thread starter macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #13
    Ok, figured out that the Input Menu is shown if you are showing the Keyboard Input menu in your menu bar (the little flag to set your keyboard to different countries, languages, etc).

    I trashed spotlight plist as well with no luck either.

    -Kevin
     
  13. netnothing thread starter macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #14
    Still having the same issues on all 3 machines. I tried everything I could think of last night. After the 2nd reboot and the spotlight shortcuts not working, I was at least able to manually reset them through Keyboard & Mouse, and it seems to be sticking now.

    Still having the issue loading the actual pref pane. The spotlight pref pane usually loads fine if selected from the bottom of a spotlight search.

    If I choose it from the main System Preferences window, most times it just hangs and doesn't load.

    Hoping some others can check today as they get iLife '09 installed.

    -Kevin
     
  14. MaskingTape macrumors regular

    Joined:
    Jan 9, 2009
    #15
    The new iLife updates that apple released today fixed the problem for me. It was the iLife media browser. Said it was for 08 only but still showed up in my updates so I installed it anyway. All is good now! (i did have to reset the spotlight shortcuts tho)
     
  15. netnothing thread starter macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #16
    Awesome...thanks. Just updated 2 of the 3 machines and everything is back to normal.....other than I did have to reset the Spotlight shortcuts again.

    Guess that's what I get for getting a copy from Best Buy before Apple wanted me to! :p

    -Kevin
     

Share This Page