iLife 09 upgrade nerves. Anyone had problems?

Discussion in 'Mac Apps and Mac App Store' started by lightwavejunkie, Jan 27, 2009.

  1. lightwavejunkie macrumors newbie

    Joined:
    Feb 16, 2008
    #1
    Hi,

    When i Upgraded to iLife 08 from 06 it trashed my iweb files and all my websites had to be rebuilt. I now have an huge photo library, lots more websites and am worried that upgrading with all my photos etc on my mac might kill or lose my data.

    Has anyone had any problems upgrading in this fashion or should i be ok to just jump in?

    I cannot afford to lose my websites and photos right now!

    Any comments here welcome!

    Cheers
     
  2. irene1975y macrumors newbie

    Joined:
    Jan 26, 2009
    #2
    backup your data before upgrade to ilife 2009?;)
     
  3. lightwavejunkie thread starter macrumors newbie

    Joined:
    Feb 16, 2008
    #3
    Did you lose data when upgrading? i plan to make a copy of my iphoto file but not sure about my iweb one?

    Any advice?
     
  4. SCStevens04 macrumors member

    Joined:
    Jun 7, 2006
    Location:
    NC
    #4
    Seems error free for me but I've really only spent time in iPhoto... don't have a website to check. BTW, love the new iPhoto
     
  5. lightwavejunkie thread starter macrumors newbie

    Joined:
    Feb 16, 2008
    #5
    did everything just update from the box and upgrade your existing progs to new ones then without a hiccup?

    No loss of data or quirky behaviour?
     
  6. JavierDiaz4 macrumors member

    Joined:
    Sep 12, 2007
    #6
    I only checked Iphoto, IMovie and IWeb. All of those work as it should. Only issue I have with all of them is that when I open them up, the welcome tutorial videos don't work. But they are online, so its not a big deal.

    I wish IWeb had more than just two new themes. Two themes, come on apple. Iphoto, the Faces is fun and all and the places is just "cool" Only used it for about 3 hours, so need more time to play to get a good feel for it.

    :confused:

     
  7. lightwavejunkie thread starter macrumors newbie

    Joined:
    Feb 16, 2008
    #7
    thanks for the replies guys, ill keep fingers crossed when i update but ups still not delivered yet grrrrrr:mad:
     
  8. John.B macrumors 601

    John.B

    Joined:
    Jan 15, 2008
    Location:
    Holocene Epoch
    #8
    I don't even install the patches for a few days, to give other people time to report problems, etc. I would never upgrade OS X or important software the day its released. Let other people verify that any upgrade is ready for prime time before installing it on your computer.
     
  9. sickmacdoc macrumors 68020

    sickmacdoc

    Joined:
    Jun 14, 2008
    Location:
    New Hampshire
    #9
    I have to ask- is there something so critical for you to do in iLife 09 that you have to install it prior to backing up, particularly in light of your previous difficulties?

    Given most people will have absolutely no problem with the upgrade in every update/upgrade that is produced some very small percentage of people have some bizarre unexpected failures to complete-- a power loss during updating, simple failure of the update to complete correctly, a glitch in their hard drive, third party software incompatibility, etc. etc. etc.

    I just don't want you to be one of those people particularly when you say right off the bat that
    As long as you realize that there is a realistic chance of you losing your sites, etc. by choosing to update without backup then fine it your choice. Just shoulder the responsibility and risk, and don't put too much faith on the reports of others regarding it as they are not running your system which could react totally differently to the upgrade ok? ;)
     
  10. wilsonlaidlaw macrumors 6502

    wilsonlaidlaw

    Joined:
    Oct 29, 2008
    #10
    iLife 09 - seamless upgrade

    All five of our Macs (Macbook, Mac-Air, Intel iMac, G5 iMac and dual g5 Powermac) upgraded absolutely seamlessly to iLife 09 from the family pack. I was concerned that iPhoto Library Manager (Fat Cat Software) would not work, switching between my various internal, server and external libraries but it works just fine. Took quite a long time to reset metadata on libraries but they are very big (50GB, 190GB, 165GB and 211GB).:)

    Wilson
     
  11. John.B macrumors 601

    John.B

    Joined:
    Jan 15, 2008
    Location:
    Holocene Epoch
    #11
    To the OP, if you do a Time Machine backup of your entire computer, that would at least ensure you could put it back the way it was before you started.
     
  12. Luis Ortega macrumors 6502a

    Joined:
    May 10, 2007
    Location:
    Fetcham Surrey UK
    #12
    Is it possible to go back to ilife 08 once you install ilife 09?
     
  13. lightwavejunkie thread starter macrumors newbie

    Joined:
    Feb 16, 2008
    #13
    Thanks for concerns but i have a substantial backup with time machine to a drobo, have seperately backed up iphoto library file and iweb domains files, just last time i updated the iweb domains in particular were not compatible and it would not import my sites and i had to rebuild them all from scratch ( I have quite a few sites now)

    My concerns were really if the changes were more just features than complete overhaul as i know snow leopard only round the corner and didnt want my iWeb and iPhoto librarys to become a pain to migrate.

    After spending the best part of 2 weekends scanning my old photos on to my mac and touching them up and adding to iphoto i was dreading ANYTHING going wrong this time! :eek:

    I like my software to be up to date and always upgrade my struff like iLife but after last time i thought id do some reseach to avoid another catastophe.

    If worst came to worst and i restore my mac ill be back to how i am now quickly enough. just trying to be cautious this time.

    Thank you all for your valid comments, unfortunately my copy did not arrive :(

    Hopefully will be here tomorrow and im much more confident of a smooth transition now thanks to you all!
     
  14. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #14
    Don't you have backups of your data? And no, Not just Time Machine but backups that are disconnected and stored in a safe place
     
  15. seattle macrumors 6502

    Joined:
    May 15, 2007
    #15
    I just used iWeb 09 to publish my blog and it lost all the photos I had. The pages are there but all photos are gone. The rest of the site seemed to publish OK and it is just my blog so no big deal. I backed up my domain file and can just use one of my other Macs to work on my site if I need too. I have my own domain and used publish to a folder option.

    Update:
    I just checked my website remotely and it works fine but for some reason on my internal network I cannot see photos on my site. I will test it more later.

    Update #2:
    It works now. It must have been a cache issue.
     
  16. khunsanook macrumors 6502

    khunsanook

    Joined:
    Jul 2, 2006
    Location:
    East Asia
  17. huppeltje macrumors newbie

    Joined:
    Jan 31, 2009
    #17
    I have upgraded and have found some trouble with iWeb 09.
    See here:
    http://web.me.com/heli1/Test/Blank.html
    iWeb can cause trouble. The ftp apparently is not working as it should. And strange things happen when you make changes on iWeb pages that were created with iWeb 08, like disappearing images.
    It is bugged. I suppose it would be allright for people who start with iWeb 09.
    There appears to be some trouble with iWeb blogs and galleries. Stuff disappears.
    So I would advise you to wait a bit with iWeb at least. You can do a custom install and leave out those apps you think troublesome.
     
  18. rylin macrumors 6502

    Joined:
    Aug 18, 2006
    #18
    I no longer have any flagged photos, and it's pissing me off:(
     
  19. rylin macrumors 6502

    Joined:
    Aug 18, 2006
    #19
    Aaaaand it seems my RAW adjustments have gone missing as well.
    Blargh, now I know what I'll be doing tonight.
     
  20. maestrocasa macrumors regular

    Joined:
    Aug 16, 2007
    Location:
    Somewhere on the Buffalo National River
    #20
    I'm anxiously awaiting my Mac Box Set. i'm going for the whole kit and kaboodle (whatever that is) at once. Jumping to Leopard and updating all the software.

    I recommend CarbonCopyCloner as a backup. bit-by-bit copy of your entire harddrive. If the proverbial spit hits the fan, you can revert and try again.

    it did take close to 4 hours to back up my 160 GB, though. :-(
     
  21. techfreak85 macrumors 68040

    techfreak85

    Joined:
    Jan 13, 2008
    Location:
    Places
    #21
    my only issue so far is the facbook/flickr uploader. but im pretty sure its just my account cause it works on another account on my same computer, with the same library.
     
  22. lightwavejunkie thread starter macrumors newbie

    Joined:
    Feb 16, 2008
    #22
    No more worries

    Well after extensive backing up prior to upgrading everything went smoothly, my iphoto library all intact and working perfectly and my iweb pages seem to all be fine with no corruption to the domains file.

    have tested the facebook notification of blog updates and all seems good.

    will test further and report any issues but seems my nerves were un necessary.
     
  23. nataliekolbeck macrumors newbie

    Joined:
    Dec 11, 2009
    #23
    Install of iLife 09 on more than one computer

    Has anybody tried to install iLife 09 on more than one computer???? I want it on my iMac and my powerbook but don't want to purchase the family version.
     
  24. techfreak85 macrumors 68040

    techfreak85

    Joined:
    Jan 13, 2008
    Location:
    Places
    #24
    That is Illegal you know right?
     

Share This Page