Resolved iLife '11 Apps say updates are available, but Software Update doesn't

Discussion in 'Mac Apps and Mac App Store' started by JKK photography, Apr 7, 2011.

  1. JKK photography, Apr 7, 2011
    Last edited: Apr 8, 2011

    JKK photography macrumors regular

    JKK photography

    Joined:
    Jul 14, 2009
    #1
    Everytime I have any iLife app (except for iPhoto '11) look for updates, it finds them. It then prompts me to open Software Update to check for updates.

    However, when Software Update searches for them, it doesn't find any. It simply says that there are no updates.

    Anyone have any reason why? Right now, it isn't affecting me much. However, I can see this getting extremely annoying in the near future.

    Thanks :)
     
  2. Duff-Man macrumors 68030

    Duff-Man

    Joined:
    Dec 26, 2002
    Location:
    Albuquerque, NM
    #2
    Duff-Man says....odd, I've not heard of that problem before. Seems like something is a bit "out of sync" between the iLife apps and software update, perhaps with the pkg receipts forlder.

    I might be inclined to try manually downloading the latest updates for the apps that this happens in/with and applying them - that may resolve the issue and shouldn't do any harm.....oh yeah!
     
  3. G4DP macrumors 65816

    Joined:
    Mar 28, 2007
    #3
    I know you mat already have thought of this, but if you purchased them through the App Store it is through that you have to update.

    Otherwise do as the duff suggests and download the links directly from Apple.
     
  4. JKK photography thread starter macrumors regular

    JKK photography

    Joined:
    Jul 14, 2009
    #4
    I'll try doing that and report back. Thanks for the idea; I wasn't aware that you can get the iLife updates directly from Apple in the same way that you can OS X updates.

    No, they came in a CPU drop-in for my MBP, so I can't get the updates from the Mac App Store. Good idea, though.
     
  5. JKK photography thread starter macrumors regular

    JKK photography

    Joined:
    Jul 14, 2009
    #5
    Alright, I did what you suggested. No cigar; still didn't work. So, I uninstalling the whole iLife suite and then reinstalling it.

    Still doesn't work. Except now, iPhoto won't open at all and instead wants me to "Open Software Update to install the latest version." That's great, except that Software Update says that I have no software that needs to be updated.

    Any other ideas? This is now very annoying, since iPhoto won't open at all.

    Thanks for any help, guys. :)
     
  6. roadbloc macrumors G3

    roadbloc

    Joined:
    Aug 24, 2009
    Location:
    UK
    #6
    You haven't moved any of the iLife Apps to a custom folder have you? Many people group their iLife Apps into a iLife folder in the Applications folder which causes this.
     
  7. JKK photography thread starter macrumors regular

    JKK photography

    Joined:
    Jul 14, 2009
    #7
    Yes, I have actually. So I should remove them from that folder?

    Thanks for that bit of advice... That was the last thing I would have tried. Need occured to me.
     
  8. JKK photography thread starter macrumors regular

    JKK photography

    Joined:
    Jul 14, 2009
    #8
    Alright, thanks Roadbloc. That fixed this problem.

    Thanks all :)
     
  9. Duff-Man macrumors 68030

    Duff-Man

    Joined:
    Dec 26, 2002
    Location:
    Albuquerque, NM
    #9
    Duff-Man says....ahhh, bangs head on the table (bar?) - should've known that as I went through that ages ago (10.1?) when I'd moved Safari to a folder I made for "internet" apps.....oh yeah!
     

Share This Page