Illustrator CS3 crashing after Yosemite upgrade

Discussion in 'OS X Yosemite (10.10)' started by sjp72, Oct 17, 2014.

  1. sjp72 macrumors newbie

    Joined:
    Oct 17, 2014
    #1
    I have just upgraded to Yosemite on my 2010 Macbook Pro. Everything seems to be running great except Adobe Illustrator CS3. The rest of the Adobe creative suite works fine - Photoshop, Indesign etc but not illustrator. When I first launched the app after the upgrade I was asked to install a Java upgrade which I did, I then re-launched Illustrator, it opened the initialising window and looked like it was going to work but it froze and I had to force quit. Now it doesn't get passed the initialising window and just doesn't open. I have cleaned the font cache and I have started my mac in safe mode, illustrator works in this mode, but when I start up again as normal it still doesn't work there. I have tried to find the preference file in users so I can delete it but I can't find this file and not really sure if this is what I need to do to get it working anyway! Sadly I don't have the installation discs so am unable to uninstall and then re-install the Suite. If anyone can give me help I would be very grateful! Just now I am very frustrated and wish I had never upgraded! Thanks in advance, and thanks for taking the time to read my thread.
     
  2. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #2
    CS3?? am amazed you've had it working this long.

    try re-downloading and reinstalling java, see if that helps. google the issue...
    some people are reporting that the app DOES work in yosemite, so research that a bit.

    roaring apps

    otherwise, time to update?
     
  3. sjp72 thread starter macrumors newbie

    Joined:
    Oct 17, 2014
    #3
    Hi Fisherking, thanks for your reply. I did do the research before I upgraded to Yosemite as the last thing I wanted was problems with Adobe...I would love to upgrade Adobe but sadly do not have the money to do that just yet. I have reinstalled Java but this did not work either. Thanks
     
  4. allycs, Oct 25, 2014
    Last edited: Oct 25, 2014

    allycs macrumors newbie

    Joined:
    Oct 25, 2014
    #4
    Workaround

    I also had problems with Adobe Illustrator CS3 and Yosemite. After the upgrade I installed Java for OS X 2014-001, as suggested by others. This seemed to work (sometimes) but when I opened Illustrator for the 2nd time it failed to open. Illustrator opened without crashing, but it did not show any menus, if I opened an .ai file the file did load and show on the screen, but I could not click on the window (unresponsive). Essentially this made Illustrator useless. I tried the following:

    • Re-installation
    • Install Java for OS X 2014-001
    • Cleaning font cache
    • Checking permissions
    • Installing other versions of Java (both JRE and JDK)

    Nothing seemed to help. I found the solution by accident:

    1. Open System Preferences > Java
    2. Wait for the Java Control Panel to load
    3. Open Adobe Illustrator (while keeping the Java Control Panel window open)

    You can also make a launcher with AppleScript to automate the process:

    Code:
    tell application "System Preferences"
        activate
        set current pane to pane "Java"
    end tell
    tell application "System Events"
        repeat until exists process "Java Control Panel"
            delay 1
        end repeat
        quit
    end tell
    delay 2
    tell application "Adobe Illustrator"
        activate
    end tell
    tell application "System Preferences" to close every window
    do shell script "killall java"
     
  5. hilleljw, Mar 6, 2015
    Last edited: Mar 10, 2015

    hilleljw macrumors newbie

    Joined:
    Mar 16, 2009
    #5
    can't load JavaforOSX2014

    The solution in the last post sounds positive, but I can't find JAVA in my System Preferences after installing (successfully, I'm told by the computer) JAVAforOSX2014. So I can't do either step 1 or 2. And creating an application launcher in Applescript and knowing what to do once I've created it is a bit above my experience level, though I'm working on it now.

    Any help with solution 1 would be appreciated.

    update: March 10. I have been able to install a JAVA update (version 8 update 40) and now have a Java button in my system pref. menu. And Illustrator CS 3 is working fine. A bit slow in responsiveness but I'm really happy to be able to use it...
     
  6. cdallabetta macrumors newbie

    Joined:
    Mar 1, 2016
    #6





    I was having this exact same issue. Thank you for this work around. It appears to be working.
     

Share This Page