Illustrator- shift not constraining shapes?

Discussion in 'Design and Graphics' started by londonweb, Jul 26, 2006.

  1. londonweb macrumors 6502


    Sep 14, 2005
    God, I hate illustrator:mad: Whatever happened to Freehand?

    Anyway, can anyone suggest why all of the sudden when I hold the shift key whilst drawing a shape it doesn't constrain the proportions like it should do? Have I accidentally turned something off?
  2. JasonElise1983 macrumors 6502a


    Jun 2, 2003
    Between a rock and a midget
    What version of Ilustrator is it? I remember when i got cs that i had the same problem, and it was caused by running entourage 2004 at the same time or something like that. Like i needed to open Illustrator before Entourage to get Illustrator to work right. It was wierd whatever it was.
  3. beatsme macrumors 65816


    Oct 6, 2005
    I know this is old-school, but have you tried throwing away the preferences?
  4. iMeowbot macrumors G3


    Aug 30, 2003
    There was a service pack that was supposed to fix Entourage so that it wouldn't be so greedy about grabbing modifier keys.

    Other people have reported success toggling their international (keyboard) settings.

    There are about 12.6 quadrillion threads on this in the Adobe support forum.
  5. londonweb thread starter macrumors 6502


    Sep 14, 2005
    Thanks guys, not sure what it was, I'm not running entourage but a system restart seems to have fixed it...
  6. pathai macrumors newbie

    Mar 16, 2010
    shift-not contstraining; option+shift-not duplicating

    I was having the same problem which landed me here. I am using Illustrator CS3 and Firefox v3.6. I've been using FFX3.6 without issue since release. However, I added Yslow and Pixel Perfect to the Firebug console yesterday and this issue presented itself.

    After reading various Entourage/Illustrator issues in this thread I shut down each program running one by one, restarting illustrator and trying the shift drag command and by process of elimination FFX was the cause.

    I am not entirely sure that Yslow and Pixel Perfect are the cause but that is the only thing that has changed on this machine when this issue came up.

    Hope this helps some other poor soul having this problem.
  7. gitgan macrumors newbie

    Dec 4, 2010
    Same issue - same resolution

    There seems to be something in the FF beta versions that makes this happens. I am running Ill CS3, when I had FF 4 Beta running, no constraining. Quit the beta and opened FF 3, everything works.
  8. davedee65 macrumors regular


    Apr 7, 2010
    I'm using the Firebox 4 beta and Illustrator CS5, all is well until I log into my .me account via Firefox and there goes the shift key, space bar and constrain proportions in CS5!! Only fixed by quitting Firefox. Go figure??!!
  9. Trevalin macrumors newbie


    Dec 7, 2010
    Loganville, GA
    I've ran into this silliness as well, and after a bit of searching, it turned out that whenever I had Hotmail open in a Firefox browser this would happen. It would also monkey with various hot keys in Illustrator CS4 too, like the spacebar.

    I have no idea why this would be the case, but the solution was to always log out of Hotmail and close that tab. Crazy I know.
  10. Hermes Monster macrumors 65816

    Hermes Monster

    May 4, 2010
    I had the same problem, and same fix yesterday :confused: only had illustrator and safari open
  11. Keitto macrumors newbie

    Feb 2, 2009
    Yep, same thing just happened to me. Had to quit FF 4B. Though it seems it erased my CS4 preferences, shift+scale and hand tools work just fine now.

    Crazy, crazy stuff.

Share This Page