I'm at my wit end! Cant restore anything with disk utility!

Discussion in 'macOS' started by linkandzelda, Apr 24, 2011.

  1. linkandzelda macrumors regular

    Joined:
    Nov 8, 2010
    #1
    Hey,
    I'm trying to scan an image for restore, its a .iso file but Disk Utility is being a pain. It says invalid argument when i try and scan it. I've scanned and restored this image a load of times before, but not this time. I have a .dmg which restores without a problem...

    Any ideas?
    Thanks in advance,
    Link
     
  2. spiffers Suspended

    Joined:
    Apr 12, 2009
    #2
    Have you tried to fix Disk Permissions? Sometimes it helps on weird system behavior.
    Disk Utility -> Choose Startup Disk -> Click Repair Disk Permissions
     
  3. linkandzelda, Apr 24, 2011
    Last edited: Apr 24, 2011

    linkandzelda thread starter macrumors regular

    Joined:
    Nov 8, 2010
    #3
    I just tried that with no luck... I also tried converting it but still no luck.. I'm wondering what's going on now.

    EDIT: Now the old one isnt scanning i'm getting operation timed out and cant allocate memory and invalid argument all sorts of weird stuff!

    EDIT2: Disk Utility decided to corrupt my old image now! Arrrgh! But the good news is the .iso is now restoring without needing to be scanned... What the? lol
     

Share This Page