I'm convinced the Watch doesn't actually connect to the iPhone via wifi

Discussion in 'Apple Watch' started by iBlazed, Aug 7, 2015.

  1. iBlazed macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #1
    From what I've read, when you're out of Bluetooth range and you're connected to Wifi on your iPhone, your Watch should still connect as long as it's connected to the same network your phone is. It doesn't do this for me and never has. When I'm a room away from my iPhone, I can't take a call or even pull up the weather. It's really effing annoying. My iPhone is always connected to my home wifi network but my Watch doesn't seem to. It's not a hardware defect because this is my second Watch (had it replaced for another reason) and they both did this. My phone pretty much has to be in the same room as my Watch or I can't do anything. Am I doing something wrong?
     
  2. Givmeabrek macrumors 68030

    Givmeabrek

    Joined:
    Apr 20, 2009
    Location:
    NY
    #2
    What freq. is your wifi? The watch will only connect to 2.4 GHZ. Which means you iPhone needs to be connected to the same thing for the watch to get the credentials. It will not connect to a 5 GHZ network.
     
  3. JayLenochiniMac macrumors G5

    Joined:
    Nov 7, 2007
    Location:
    New Sanfrakota
    #3
    Sure, just because it doesn't work for you, it must not connect to wifi for the rest of us.

    Tell us about your wifi network. The Watch cannot connect to 5 ghz networks.
     
  4. iBlazed thread starter macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #4
    Ah, that must be it. I'll give it a shot. That's a damn shame though. 5G seems to work much better on my iPhone.

    EDIT: Scratch that, seems my phone has been connected to 2.4ghz all along. What else could the issue be?
     
  5. Shadowbech macrumors 68040

    Joined:
    Oct 18, 2011
    #5
    Have you tested by doing the following steps?

    1. Turn off AW
    2. Forget your network on your iPhone.
    3. Connect to your network that isn't 5 GHz
    4. Turn on AW
    5. Once AW completely loads, turn off bluetooth
    6. You can test by going to any app that requires data and see if it will pull data.

    This has worked for me and I don't even have to turn on bluetooth.
     
  6. JayLenochiniMac macrumors G5

    Joined:
    Nov 7, 2007
    Location:
    New Sanfrakota
    #6
    Try forgetting the network on iPhone and re-connecting while it's in Bluetooth range. This will ensure the wifi password gets transmitted to the Watch. This sometimes doesn't happen if you've been connected to the network on iPhone before you received your Watch.
     
  7. iBlazed thread starter macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #7
    It seems to work now without me having to do anything. I turned off bluetooth to test it and it's still connected even in the next room. Could is be that the iPhone sometimes drops wifi and switches to LTE when it's idle?
     
  8. PilotC150 macrumors member

    Joined:
    Apr 24, 2015
    #8
    I've been noticing the same issues as the OP. Just did those steps, and still no luck for me.
     
  9. deany macrumors 68020

    deany

    Joined:
    Sep 16, 2012
    Location:
    North Wales
    #9
    do you use powerline adapters to extend wifi coverage?
     
  10. powerbook911 macrumors 68040

    powerbook911

    Joined:
    Mar 15, 2005
    #10
    I have the same use experience as the OP. I thought it was made this way , no?

    Now, mine does stay on the Wi-Fi network and I can do things that are fully installed on the watch like email and message app which seem more independent compared to some of the other apps like weather. However, anything that uses the phone (even some of the apple apps like weather), if out of bluetooth range, simply doesn't work. I thought it was like this for everyone, no?
     
  11. danmart macrumors 6502

    danmart

    Joined:
    Apr 24, 2015
    Location:
    Lancs, UK
    #11
    I can get the connectivity via wifi to work, but it takes coaxing.

    First, watching my network via AirPort Utility I can see an additional client connect to my network when I turn Bluetooth off on my iPhone, so it is definitely connecting.

    With Bluetooth off I attempted to get weather info, and got a red 'no iPhone connection' icon. I tried this again, same effect.

    Next, I tried sending a text to my work phone, which is a Blackberry. It sent, and arrived at the Blackberry as an email! But it did send.

    I then went back to weather out of curiosity, and now it would work fine over wifi.

    My network is provided by a latest generation Time Capsule, so a/b/g/n/ac.
     
  12. powerbook911 macrumors 68040

    powerbook911

    Joined:
    Mar 15, 2005
    #12
    Wow. I never knew it had this capability. I thought you HAD to be in bluetooth range per my results and per discussions I had heard on some podcasts.

    This would make the watch 10x more useful around home if all the features worked and stayed connected to your phone via WiFi.

    However, at the limits of bluetooth, I always found I could only do things as I stated, like email and messages.

    With your post though, I tried turning off bluetooth, and wow! Everything worked between phone and watch, plus fast!


    The problem now seems clear to me: The bluetooth hangs on just barely enough a few rooms away, that it doesn't actually perform, but at the same time, it prevents it from switching to Wi-Fi.

    Hopefully there is someway they could update software in the future so that if the bluetooth starts to get weak, it automatically moves to a Wi-Fi connection between the devices.

    Of course, considering on my iPhone (mature product) I can be 7 houses away and it tries to hang onto my network rather than switch to cellular, I won't hold my breath.
     
  13. shortcrust macrumors 6502

    Joined:
    Aug 7, 2008
    #13
    Your phone can be on 5 and your watch on 2.4. It works for my router at least, and lots of people have said the same in other threads. However, your phone needs to be on the 2.4 initially to get the watch to connect. That only needs to happen once, then the phone can go back to the 5.
     
  14. Rok73 macrumors 65816

    Rok73

    Joined:
    Apr 21, 2015
    Location:
    Planet Earth
    #14
    This. I have a dual band router with 2.4 and 5 GHz band. My iPhone 6 connects to the 5 and my Apple Watch to the 2.4 GHz network. I also can see it in my router logs. Works flawlessly for me.

    I didn't need to connect the phone to the 2.4 GHz network in order for it to work, though. It always connects to the 5 GHz band automatically anyways.

    But I can imagine that it doesn't work that good on routers with bad firmware e.g.
     
  15. iBlazed thread starter macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #15
    Yeah I'm starting to think the iPhone switches to LTE when idle and that's why the watch doesn't always connect via wifi when it should. It's very spotty. Sometimes it works and sometimes it doesn't. Unfortunate because it's a pretty important feature. Hope they fix it.
     

Share This Page