I'm having problems restoring my iPhone

Discussion in 'iPhone Tips, Help and Troubleshooting' started by atsegai, Jun 14, 2017.

  1. atsegai macrumors newbie

    Joined:
    Jun 14, 2017
    #1
    I decided to revert my iPhone's current version which is iOS 11 Beta and restore it back to iOS 10.3.2. I connected my phone to my laptop and began the restoration process. My phone restarted and had the apple logo and the progress bar. Once the progress bar reached the end, it was stuck and didn't move. Everytime I try rebooting my device it restarts the entire process again and gets stuck at the end. When I plug my phone into my laptop, I can't continue restoring my iPhone through iTunes since my iPhone isn't being recognized on iTunes. Anyone have ideas on how I could resolve this issue?
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #2
    Have you tried recovery mode or DFU mode?
     
  3. atsegai thread starter macrumors newbie

    Joined:
    Jun 14, 2017
    #3
    DFU mode didn't work but recovery mode worked. Thanks so much!
     

Share This Page