I'm not able to define words in iOS 6 on my 3GS

Discussion in 'iOS 6' started by snverhallen, Sep 24, 2012.

  1. snverhallen macrumors 6502a

    Joined:
    Oct 17, 2007
    #1
    In iOS 5 I was able to highlight a word and get the definition of it when I tapped on 'Define.'

    Now in iOS 6 when I highlight a word and get the popover I only get the 'Copy, Paste, Select All and Suggestions' options. I've tested this in both 3rd party and stock Apple apps to make sure it's not an app-specific issue.

    I'm a bit disappointed because this is a little feature I use all the time.
     
  2. bezdaniel macrumors member

    Joined:
    Sep 24, 2007
    #2
    I am experiencing the same issue. Let me know if you find a fix!!!
     
  3. snverhallen thread starter macrumors 6502a

    Joined:
    Oct 17, 2007
    #3
    Doesn't anyone else see this on their iPhone 3GS running iOS 6?
     
  4. coarserocks, Oct 13, 2012
    Last edited: Oct 14, 2012

    coarserocks macrumors newbie

    Joined:
    Jun 18, 2003
    #4
    Same here - workaround found

    Yea I saw the same thing on my iPhone 5. What happened to me is I went to the define option and then was told that I need to download a dictionary. For some stunningly inane reason they have no longer included it. Upon clicking download I was told to connect to Wi-Fi. So I switched to settings, flipped the switch on Wi-Fi, then went back to find the download option. It was no longer there - just missing entirely.

    I tried force-quitting the app I was in and I tried a soft reset, both to no avail. After researching online I found a workaround. If you go to Settings -> General -> International -> Language, set your language to 'British English'. Then when you go back to find the download option it will now be there again. Be sure you're connected to Wi-Fi before you press the button because apparently you only get this one shot. It took a moment to download the dictionary, then I went back to settings and changed my language back to 'English' and the dictionary now functions. Of course I'm still left wondering whether there's any difference in the British dictionary or the American dictionary.

    My satisfaction with iOS 6 has been extremely low. I am seething to be completely honest and I'm fighting every urge to press the caps lock key. I know ranting does no good at all - this forum is flooded with angry trolling and I always just skip right past it. But I never could have imagined how much iOS 6 would harm the efficiency and power of my iPhone. Maps has screwed me over huge. So huge. I was late to work just this morning. I'm juggling 4 transit apps at the moment (Google maps on my homepage makes 5) and they all suck. I was so excited to get my iPhone 5, but unfortunately I think I am going to sell it unless I can find a way to install iOS 5. I'm hoping someone will find a way to re-flash the firmware on the phone to make this possible, as I know there have been countless people who have been loyal to Apple for years who find iOS 6 unacceptable.

    Apple's never let me down before this week. I just can't wrap my head around why they opted to take so many steps backwards with their latest iOS. There are no words for the anger and disappointment that I have towards Apple right now. They've just about lost me for good.
     
  5. mobnmob macrumors newbie

    Joined:
    Feb 10, 2013
    #5
    I am having the same problem of not having the define word. Apple has done **** with this feature with iOS 6.1.1
    I'm having lots of problem because of it. I have wasted time and money on it. Is there any replacement to that? No.
    Silly engineers of apple. They have gone crazy.

    ----------

    I hate apple.
    And will hate it until they make this define feature okay again.
    Ill tell people until then not to buy apple products and instead go for android devices.
     
  6. justinparadise macrumors newbie

    Joined:
    Mar 31, 2013
    #6
    All the answers are here!

    Follow these steps if you have this problem!!!!!!!

    1. Go to Settings>General>International>Language
    2. Change the language to one of Apples supported languages like Spanish.
    3. Go to your notepad, type "test", press hold, select the word, and click the "define" that now appears.
    4. This will tell you there is no current dictionary, and prompt for one to be downloaded.
    5. Assure you are on a stable Wi-Fi network, and hit download.
    6. Once complete, go back to your language settings and switch back to your native language.
    7. Enjoy your dictionary feature without having to "reset" your phone.

    From me to you :apple:
    I worship you TrickNostril for giving me the answer. All kudos to this person!

    Love, justinparadise
     
  7. glenncal macrumors member

    Joined:
    Jun 7, 2009
    #7
    I had the same problem, and the above methods weren't working. Instead, what finally worked was changing the keyboard to English(UK) from Settings->General->International->Keyboards
     

Share This Page