I'm not giving up on the 1.1 yet. Maxxing it out.

Discussion in 'Mac Pro' started by ADDvanced, Nov 11, 2015.

  1. ADDvanced, Nov 11, 2015
    Last edited: Nov 11, 2015

    ADDvanced macrumors newbie

    ADDvanced

    Joined:
    Nov 8, 2015
    #1
    So I have a Mac Pro 1.1.

    As you guys know, it has the 32 bit EFI, but I bought it pretty heavily upgraded already.

    Specs
    Dual Quad 3.0ghz Xeons
    32 gigs ram
    Ati 5770
    Twin 500 gig HDs

    I bought this machine for around $1200 a few years ago, sold the cinema display that came with it, and so I had about $900 into it. I purchased a 128 gig SSD for 10.6.8 and win7, then put the twin 500 gigs in RAID array for media redundancy. I used it primarily for doing CAD modeling (solidworks), rendering and animation (Keyshot) in bootcamp; Layout and video editing in OSX.

    That was fine for a few years. I did freelance after my normal job, and I wound up making around 20 grand with this machine, but honestly it's still been rock solid and due to the SSD, usability is amazing. Feels brand new.

    Anyway, due to the size of Windows 7, I was running out of room in a 75 gig Bootcamp partition. I ordered a 240 gig SSD, and threw that into bay 2.

    I then downloaded 10.10 El Capitan onto a 32 gig USB stick, but it wouldn't install due to my 32 bit EFI.

    So I removed all my drives except the new SSD, and hooked up the Mac Pro to my 13 MBP using a Firewire 800 cable, and booted from the USB on the Macbook Pro. I selected the target SSD, install went smoothly.

    Due to the 32 bit efi, was not done yet.

    I needed to reinstall all the old drives, so I booted into Snow Leopoard. I downloaded the 32 bit/64 bit EFI hack from here:

    http://piker-alpha.github.io/macosxbootloader/

    Installed that according to instructions here:

    2006/2007 Mac Pro (1,1/2,1) and OS X El Capitan

    I then downloaded bootcamp, but that said it wasn't compatible, so I had to do some ******** with that too. I used the stock bootcamp tool and made the partition, but it wouldnt' boot from the USB stick no matter how many times I tried. So I had to burn a windows 7 DVD, boot from the win7 dvd, then select the partition.... thing is, it said it was the wrong format.

    The bootcamp installed MADE the partition, but windows 7 wouldn't like it.

    So then I booted into snow leopard again, deleted the partition, booted into elcapitan again, tried again, still no dice. So then I used the windows 7 cd to reformat ONE side of the partition, and the install worked!

    So the windows 7 installed, but I had no drivers. The bootcamp drivers from Apple would not run, it gave me an error message saying the computer was not 64 bit compatible. LIES!!!!

    So then I had to figure out how to get around that, using some ******** command line thing to run it in a different compatibility mode, I don't even remember.

    Thing is.... I didn't read the requirements on Fallout 4, and the 5770 doesn't meet them. So now I ordered an AMD 7970... should be here this Friday. Best card I can fit in this thing. Probably the last upgrade I'll do to this machine, but I'm hoping it sticks around until 2020 or so. :)

    So anyway. Now things are fine. Everything works. But what a pain in the ass. Back to another 4-5 years of not playing tech support again.

    Cheers!
     
  2. devon807 macrumors regular

    devon807

    Joined:
    Dec 31, 2014
    Location:
    Virginia
    #2
    I did the same exact thing to mine, then I got a 3,1 :) Good luck with your upgrades! BTW, do you know how much a good 7970 would cost, looking into buying one myself to replace the aging 2600XT
     
  3. ADDvanced thread starter macrumors newbie

    ADDvanced

    Joined:
    Nov 8, 2015
    #3
    About $250 on eBay.
     
  4. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #4
    If $250 on ebay, I think $299 form MVC may be a better choice.
     
  5. tripmusic macrumors 6502

    tripmusic

    Joined:
    Oct 26, 2012
    Location:
    MA
    #5
    The hacks are fun for a while, but sooner or later you just want to use your Mac instead of tweaking it all the time. Just sell that thing and pick up a 3,1. I got lucky and found one gutted out for $150. All I had to do was pop in my video card, BT/WiFi cards, ram and HD's. It had 2.8ghz chips and I upgraded to the 3.2ghz for around a $100 or so.
     
  6. ADDvanced thread starter macrumors newbie

    ADDvanced

    Joined:
    Nov 8, 2015
    #6
    Well, the last time I did all this ******** was in 2010? I think it'll be good for a while once I install the 7970, and honestly it probably won't get any upgrades after that, ever.
     
  7. cw48494 macrumors regular

    cw48494

    Joined:
    Jun 17, 2015
    #7
    My 1,1 pushes a lot of power and for $100 I don't think I could have done better, I'll be running El Capitan soon but I'm comfortable with Yosemite until Metal gets me going; I'll be pushing some better CPU's here soon, though I'm still not giving up hope that I'll find some 5350's to BSEL -- Windows 10 on the flip side is great, I can run any game out there just fine.
     
  8. devon807 macrumors regular

    devon807

    Joined:
    Dec 31, 2014
    Location:
    Virginia
    #8
    How does the R9 280X perform in modern games? What games do you play?
     
  9. cw48494 macrumors regular

    cw48494

    Joined:
    Jun 17, 2015
    #9
    Anything and everything, just got Fallout 4 and it plays well. Crysis 3, Battlefield 3/4, Bioshock infinite -- I probably benchmark games more than I play them, my 1,1 just doesn't want to quit.

    Not to mention I play at 2560x1440.
     
  10. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #10
    That's pretty damn amazing for a 9+ year old computer!

    And it's only possible because you have a PCIe slot. If the GPU was a custom board *cough cough* you'd be stuck with the original GeForce 7300 GT or a Radeon X1900 XT instead of a modern card.
     

Share This Page