im so lost right now, sync help i think?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by helios16v, Dec 1, 2008.

  1. helios16v macrumors regular

    Joined:
    Nov 1, 2008
    Location:
    Earth
    #1
    mkay well the problem i the iphone will not come up on itunes.
    im currently running 2.1 pwned firmware with a rogers sim card.

    what i am TRYING to do is downgrade to 1.1.4 since there are more games due to me not having a legal rogers iphone account to use the app store so that feature is useless to me so theres no point to have 2.x fw

    anywho back on topic i cant conect to itunes on my powerbook g4
    it worked fine on here before when i first got the phone and it even uploaded music and pictures and everything, not iphoto wont find the iphone and neither will itunes.

    so i tried another usb cable and nothing

    tried another usb port and nothing

    went through everything apple said to do with restarting the iphone

    AND reinstalling itunes and nothing has worked and lastly it said to try it on a different computer so i decided to try it on a pc and it DOES come up and itunes DOES find it so i figure ill just downgrade it to 1.1.4 on the pc but then while i was downloading 1.1.4 official firmware the iphone disconnected and then reconnected and continued doing that for a bit and then i unplugged it and replugged it back in and now it doesnt come up on either computer so im stuck with 2.1 pwned fw which sucks cause it has nothing i want, id be better off with a pocket pc right now:mad:

    so im out of idea's, and i cant send it to apple cause theres no warranty plus i should have the phone to begin with since its a 2g and im canadian

    so any idea's?
    anything at all im willing to try, even if it involves opening the iphone im willing to do that far, i need to replace my glass when the glue comes in the mail so ill be taking it apart soon anyways

    thanks for any help
    -Ben
     
  2. helios16v thread starter macrumors regular

    Joined:
    Nov 1, 2008
    Location:
    Earth
    #2
    i have solved my problem, to any one else who is having this problem 2 words..well.. 5 letters
    dfu
    pc

    put the iphone in dfu mode and it still wouldnt come up on my powerbook so i tried all my steps over again and nothing was working but then when i put it in dfu mode and hooked it up to the pc BAM conected and everything restored perfect and now it works fine.

    now my dilemma is im at 2.2fw and im trying to go to 1.1.4
    got my iphone working again but ended up going up a version in fw lol
     
  3. Hudzilla macrumors 6502a

    Hudzilla

    Joined:
    Nov 12, 2007
    Location:
    England
  4. CrzyCanuck72 macrumors 6502a

    Joined:
    Jun 10, 2003
    #4
    You don't need a legit Rogers iPhone account to use the app store
     

Share This Page