iMac 10,1 21.5 late 2009 negotiated SATA 1.5Gbps

Discussion in 'iMac' started by Dadioh, May 15, 2012.

  1. Dadioh macrumors 65816

    Dadioh

    Joined:
    Feb 3, 2010
    Location:
    Canada Eh?
    #1
    I have an iMac 21.5" Late 2009 model in which I have replaced the optical drive with a SATA sled and an OCZ Agility 3 120GB SSD. I have partitioned that 120GB into 60GB for OS X Lion 10.7.4 and the other 60GB for Bootcamp Windows 7 Ultimate.

    On a whim I decided to benchmark the SSD drive using Drive Genius. I was surprised at how low the numbers were so I opened, "About this Mac" and navigated to the SATA information. On both the internal hard drive WD Green 1TB and the SSD the negotiated link speed is only 1.5Gbps (SATA 1). I checked my other Macs that I have with SSD drives (MacPro1,1 with Intel 320 120GB, MBP13 with Patriot Inferno 60GB, and Macbook Aluminum 13" with OCZ Vertex Plus 60GB) and all of those report negotiated link speeds of 3Gbps (SATA 2) as they should.

    I have tried SMC reset and PRAM reset to no avail.

    One important thing to note... I originally had this SSD in my iMac 2008 24" and moved it over to this 2009 21.5" so the original Lion install was on a different model of iMac.

    So I am wondering if it is possible that this is some sort of driver issue or is it a hardware issue? I could take the step of doing a fresh Lion installation on this iMac (I have a time machine so getting back to where I started is easy). This would maybe answer the question of whether it is just a driver issue. But before I do that I was wondering if it is even possible that this is the issue. It sounds more like a hardware issue to me since negotiated link speed should be something that the SATA controller and SSD/Disk sort out by themselves. I thought maybe it was the SATA Sled but it seems to me that is just passing the signal through with no interface chip. Plus that would not explain why the WD 1TB drive is only negotiating SATA 1 speeds. I have the same model in my MacPro and it has no issue with SATA 2.

    Also, if I boot into Windows I know I am in IDE mode and not AHCI but the benchmarks also suggest that I am only at SATA 1 speeds. If I go into device manager I don't seem to be able to find information concerning whether it is SATA 1 or 2.

    Any thoughts?
     
  2. Dadioh thread starter macrumors 65816

    Dadioh

    Joined:
    Feb 3, 2010
    Location:
    Canada Eh?
    #2
    Here is an additional piece of info. Just to rule out that the sled was the issue I opened up the iMac and removed the WD10EADS drive and moved the Agility 3 SSD over to the primary SATA port. So that is a direct connection to the SATA port without the Sled interface. Reset SMC and PRAM and rebooted. Still negotiating 1.5Gbps. Tried a fresh installation of Lion and still 1.5Gbps.

    Checked the jumper settings for the WD10EADS online and all jumpers are open (meaning it is set for SATA2 speeds.

    So I am at a loss. Both the SSD and the WD10EADS are rated for 3Gbps but my iMac refuses to negotiate them to 3Gbps. Absolutely NO idea why. Kind of pointless having an SSD in a machine that can't even run it at SATA2.

    Any other ideas?
     
  3. Vid macrumors member

    Joined:
    Jul 30, 2008
    #3
    Not too much of a help, but I can give you some background on it would be at SATA 1.5 from the SATA side of things and a few experiments.

    1) The drives are forcing SATA 1.5. If the HDD came with the Mac it would be possible that Apple had configured it this way, but there is no reason why the SSD would do this. We can rule this out. Did the HDD come from Apple? That could matter later.

    2) The host is forcing SATA 1.5. I'm not really sure how to rule this one in our out. One idea is to take at look at the system profiler. Under SATA click on the port, not the drive. I see the following on my MBP:
    Vendor: NVidia
    Product: MCP79 AHCI
    Link Speed: 3 Gigabit
    Negotiated Link Speed: 3 Gigabit
    Description: AHCI Version 1.20 Supported

    That said, just because you see that the Link speed is 3, but the negotiated is 1.5 that doesn't prove that the host still isn't forcing it. Now if you see 1.5 for both it sounds like the port has been configured by the EFI or OS to only support 1.5. I would expect this to be true across all iMac's of the name model as yours.

    3) Negotiation failed. If they can't get a lock on 3.0 the drive and host will move down to 1.5. This could be anyones fault. The fact that both drives do it tends to imply host/routing/cable, but it could still be more complicated. Also keep in mind that if this is the case it doesn't mean anything is wrong with your Mac, it might be true that the majority of drives fail on models like yours.

    Really without moving to a protocol analyzer it is going to be harder to debug it any further. I would definitely verify that others with a similar model/year have gotten 3Gbps to work.
     
  4. Dadioh thread starter macrumors 65816

    Dadioh

    Joined:
    Feb 3, 2010
    Location:
    Canada Eh?
    #4
    Thanks for the thoughts. I suspect it is the host (iMac) that is causing the negotiated speed to drop to 1.5. The hard drive is not the original drive. The original was a WD blue 500GB 7200rpm. I still have it sitting on a shelf so I could swap it back in and see if it negotiates 1.5. Both ports indicate they are capable of 3.0. The SATA cables are the original ones that are preinstalled in the iMac so I wouldn't suspect signal integrity issues unless it came that way from the factory.

    I suspect I am in the very small minority of iMac owners with this model that opens them up and switches to ssd so this might very well be an issue with this model. Using a mechanical hard drive you would never notice it was only SATA 1 since the hard drive would have trouble saturating 1.5Gbps. It is REALLY noticeable with an SSD.

    I am thinking of upgrading to a 27" anyways so I may not invest any more time in this. I will move my ssd over to the new iMac when I get it assuming it will run at 3Gbps.

    Cheers
     

Share This Page