iMac - 10.5.4 combined update install stalling

Discussion in 'macOS' started by sreedy, Jul 11, 2008.

  1. sreedy macrumors 6502a

    Joined:
    Feb 24, 2005
    Location:
    Somerset
    #1
    Hi Guys,

    I've had a search around and cannot find this specific issue anywhere.

    I didn't install the 10.5.3 update as I just didn't get round to it, Software Update prompted me last night for the new iTunes, QuickTime and the 10.5.4 combined update.

    Download took ages but once it rebooted to do the install the installer seemed to be stuck only a few millimetres into the progress bar. I went to bed expecting it to have finished by morning but it hasn't moved at all! That's 8 hours! I turned it off and tried again but same result so far......

    I'm going to boot, repair permissions and try again...... and then if that doesn't work try and find the 10.5.3 updater and run that first.

    Anyone else had this or can offer some advice?

    This is on my iMac (the iBook updated perfectly!).
     
  2. applenewton2008 macrumors newbie

    Joined:
    Jul 13, 2008
    #2
    I ran into the same problem. Earlier today I had OSX 10.5.2 and was tring to update to 10.5.4. I ran software update and when prompted to restart it appeared to get stuck as you described.

    I did a hard shutdown and then restarted. I ran update again, same problem, hard shutdown...this this three times and same problem each time.

    I looked at the update install logs and noticed that there was an iMac EFI Firmware 1.3 update that was logged for each time I tried above.

    There was a step I was missing in that specific update: shutdown, press on button until I hear a long tone, and then release the on button. The firmware updated fine.

    I tried OSX update again but still same problem.

    I downloaded the standalone updates: 10.5.3 and 10.5.4. Since I was at 10.5.2 I did 10.5.3 first and after 10.5.4--no specific reason but just to rule out the fact that there was something not updating in the 10.5.3 update.

    Using the standalone updates by downloading from apple.com and manually installing seemed to do the trick.

    But I don't know if the root of the problem was:

    1. not following the EFI firmware update
    2. jumping from 10.5.2 to 10.5.4
    3. or if it's the auto-update vs. manual download/update install
     
  3. rstorm macrumors regular

    Joined:
    Oct 26, 2006
    Location:
    Grand Rapids, MI
    #3
    I updated from 10.5.2 to 10.5.4 with the combo with no problems. I always repair permissions before and after.
     

Share This Page