iMac 2.66GHz Intel Core 2Duo and Canon DPP-big problems, no compatibiliy??

Discussion in 'iMac' started by fabthi, Jan 29, 2010.

  1. fabthi macrumors newbie

    Joined:
    Jan 29, 2010
    #1
    Hi everybody
    I just purchased an iMac 2.66GHz Intel Core 2Duo (Snow Leopard 10.6.2) and I installed Canon Digital-Photo-Professional 3.7.3 (upgraded from Canon's website).
    I soon had big problems with the Canon Raw sw: after the start up of the application, every command I try to operate (even a simple click in the menu bar) makes the infamous coloured wheel to appear and I have to wait 10-15 seconds, and sometime more, for the command to be operated.:eek:
    I found on the Canon site this "cryptic" statement about the installation of DPP 3.7.3 on Snow Leopard:
    "Improvements to Mac OS 10.6 Compatibility Issues have been made, to fixes the following problems that occurred with Mac OS 10.6.
    ***This does not guarantee the software will work correctly in all Mac OS 10.6 environments.***"
    So what should this mean? Does it work or not? :confused::confused:
    I also tried to go back installing DPP 3.4.1 but it's the same horrible story.
    I'd like to hear from people who is experiencing similar problems with the same configuration I have (Snow Leo and DPP).
    Thanks to everybody
    Fabio
     
  2. DSPalpatine macrumors member

    Joined:
    Nov 9, 2009
    #2
    I don't have the same configuration as you, but I am running 10.6.2 on a C2D MacBook (nvidia 9400m model) with DPP 3.6.1 and have no issues.

    I had major problems with DPP when I upgraded from Tiger to Leopard with my G5 iMac, but an update to DPP cured those ills. When I was having problems, a call to the Canon tech support line was surprisingly helpful. I'd give them a try (should be on the documentation in your camera, or on the Canon website).
     
  3. fabthi thread starter macrumors newbie

    Joined:
    Jan 29, 2010
    #3
    Problem might be that to upgrade from Canon's website, Canon requires a previous version of DPP (or other Canon's utility sw) to be already installed on the machine, but I can only install from a cd with MacOs 10.4 as latest compatibility. It does install the sw anyway on the iMac but probably it's not a proper installation and therefore the following upgrade is not good either.
    I'll e-mail Canon support to try to sort this "kink". :(
     
  4. Ecoh macrumors 6502a

    Ecoh

    Joined:
    Oct 30, 2009
    Location:
    USA
    #4
    I have a 27" i7 running SL. I installed DPP from the disk that came with my camera and then updated from the Canon website. Everything has been running well.

    Have you tried removing DPP and then reinstalling from your disk ?
    Repair permissions after installing ?
     
  5. fabthi thread starter macrumors newbie

    Joined:
    Jan 29, 2010
    #5
    Maybe it depends on what version of MacOs your DPP installation disk is compatible with, mine is only good for MacOs 10.4 as latest

    Yes, but it didn't make any better; permissions were OK.
     

Share This Page