iMac 2.8 slow to sleep

Discussion in 'iMac' started by JayLenochiniMac, Feb 6, 2008.

  1. JayLenochiniMac macrumors G5

    Joined:
    Nov 7, 2007
    Location:
    New Sanfrakota
    #1
    I normally put my iMac at home to sleep at nights and it goes to sleep right away after I click on sleep from the :apple: menu. However, in the past two nights, it's been taking 30 seconds or longer (haven't really timed it) to sleep. Tried restarting but to no avail. "Safe sleep" exists in the notebooks, not the iMac, right?
     
  2. midorix macrumors member

    Joined:
    Nov 23, 2007
    #2
    Same issue on my 2.8.

    It used to go to sleep immediately from the :apple: menu.

    I would like to know the issue and solution also.
     
  3. xxjuicymintxx macrumors regular

    Joined:
    May 2, 2008
    Location:
    Grand Rapids, MI
    #3
    Was it a refurbished model by chance? Not that I can necessarily see it making a difference, but I've been thinking about trying to get the 2.8ghz refurb, so I was just curious.

    Does seem odd...
     
  4. Darkroom Guest

    Darkroom

    Joined:
    Dec 15, 2006
    Location:
    Montréal, Canada
  5. JayLenochiniMac thread starter macrumors G5

    Joined:
    Nov 7, 2007
    Location:
    New Sanfrakota
    #5
    Guess what? The problem went away after about a week out of the blue. I have absolutely no clue what happened. Didn't do anything special like software update, etc.
     
  6. midorix macrumors member

    Joined:
    Nov 23, 2007
    #6
    I think the earth, moon, and the planets were not aligned properly.

    My issue just went away.

    I closed all programs and turned off, and reboot.

    Now, if I click sleep, it sleeps immediately.

    Go figure:confused:
     
  7. NP3 macrumors regular

    Joined:
    Jul 12, 2003
    Location:
    Los Angeles
    #7
    Perhaps you were up late and the daily/weekly/monthy system cleaners ran in the background?

    I have this problem when i haven't rebooted or cleaned recently (I use a program called Cocktail)
     
  8. JayLenochiniMac thread starter macrumors G5

    Joined:
    Nov 7, 2007
    Location:
    New Sanfrakota
    #8
    I second that.

    This would not happen in Leopard though, because of how the new launchd process works in excecuting the maintenance scripts.
     
  9. NP3 macrumors regular

    Joined:
    Jul 12, 2003
    Location:
    Los Angeles
    #9
    sorry, i didn't clarify enough...i meant that perhaps the maintenance scripts cleaned out something that was slowing you down?

    Just hypothesizing here.
     
  10. JayLenochiniMac thread starter macrumors G5

    Joined:
    Nov 7, 2007
    Location:
    New Sanfrakota
    #10
    That could actually be a reasonable explanation if the weekly or monthly maintentance script kicked in to clean out the culprit of the problem.
     
  11. Muncher macrumors 65816

    Muncher

    Joined:
    Apr 19, 2007
    Location:
    California
    #11
    My 20" does that occasionally too. I just restart it to get rid of extraneous processes, and that usually does it.
     

Share This Page