Imac 20" ('07) will not boot to HD or CD

Discussion in 'Mac Basics and Help' started by maxmacaddict, Mar 28, 2010.

  1. maxmacaddict macrumors newbie

    Joined:
    Mar 28, 2010
    #1
    Holding "C" or "D" key don't work -- just keep getting the flashing folder with question mark. Hard drive is new, partioned and verified with OSX 10.4.11 (Tiger). This was done using install disk in the optical drive in target mode using a MacBook. Both CD and Hard drive:confused: access fine using the MacBook.

    Tried SMC reset, PRAM/VRAM resets, "option" key, and even tried going into open firmware and shell - nothing. Will not see either drive, will not open shell or firmware.

    Just "?" "?" "?" "?" etc. Any ideas what the problem can be?
     
  2. stridemat Moderator

    stridemat

    Staff Member

    Joined:
    Apr 2, 2008
    Location:
    UK
    #2
    To me that sounds like a logic board problem! Do you live near an Apple store?
     
  3. maxmacaddict thread starter macrumors newbie

    Joined:
    Mar 28, 2010
    #3
    don't think it is logic board --

    only because i can boot from my Imac hard drive using it as a target machine (connecting from my MacBook), and access all applications and data on the Imac, with full disk communications between optical and hard drive. And conversely, I can boot my Imac using the MacBook as target, thus using the logic board/keyboard of the Imac for all functions and everything works quite normally using the Imac machine.

    It is only when I try to boot the Imac from the Imac hard drive that I get the "?" image and the "C" key does not work to boot from the optical drive. Very strange!
     
  4. maxmacaddict thread starter macrumors newbie

    Joined:
    Mar 28, 2010
    #4
    Solved Imac booting problem

    For the benefit of others who may encounter this problem (Imac Core Duo 2.16 ghz would not recognize hard drive, would not boot to optical drive from "C", etc.) I solved the problem and here is how.

    I used "SuperDuper" (downloadable free) to copy my HD (Tiger OSX) from a PowerBook G4 to the HD on the Imac. To access the Imac hard drive, I connected the Imac to the PowerBook with the Imac in "target" mode (boot with the "T" key depressed). . In target mode (firewire connection required) I could access the Imac HD (for copying purposes) from the PowerBook screen. Then used SuperDuper to copy the Powerbook start-up disk to the Imac HD.

    After the Tiger was loaded on the Imac drive, the Imac recognized the drive and would boot to the drive -- however , all functions don't work properly because the Imac requires Snow Leopard (since it has the Intel chip) . So I then purchased Snow Leopard (ebay) and loaded that onto the Imac, and presto -- Imac booted, recognized all drives, and firmware key combos appear to work as normal. All systems are operational.

    Side note -- if you are having problems with Imac Firewire drive, as I did, this seems to work: unplug the Imac for fifteen seconds (resets the power unit); boot with pram clear key combo (option/command/p/r keys depressed together and held down) till you hear the chime repeat three times. Appears to reset the firewire ports.

    So it can be done. For some reason, I never could get the Apple provided firmware restore CD to load on the Imac properly.
     

Share This Page