iMac 2007 / 2008 - can't login after update, please help!

Discussion in 'iMac' started by Jamaway, May 25, 2015.

  1. Jamaway macrumors member

    Joined:
    Jul 20, 2010
    #1
    Hi there,

    First off, sorry for the lack of specific details but I'll give as much as I know!

    My brother has been given a 2007 / 2008 iMac (one with a black back) and he can't log in since an OS update. He doesn't know what OS he was trying to update from unfortunately, but he tells me he was trying to update to "the latest one" in March so we should assume he's tried installing Yosemite, although the background image at log in is still the space / stars image so not sure if this is the case.

    He chooses a profile, enters his password and then the screen goes briefly blue before just going back to the log in screen. If he selects 'guest' profile the box just shakes and does not go further, so he's stuck in a permenant loop. Have tried booting in safe mode but even when holding down cmd and S the iMac just boots normally and he ends up at log in screen again.

    Any ideas on what he can try to get past this?

    Many thanks
     
  2. 0d085d macrumors regular

    Joined:
    Apr 23, 2015
    #2
    Safe mode is actually the shift key. Cmd+S boots into single-user mode unless a firmware password has been set.

    What happens if you hold down the option (alt) key while booting up? See if you can boot from the recovery partition either from there or by pressing cmd+R.

    It may ask for a password (blank screen with a padlock) when booting into recovery mode. If you don't know this password then you will need to go to an Apple store. You can't do anything about a botched OS install without firmware access, and only the Apple mothership can override a firmware password.
     
  3. Jamaway thread starter macrumors member

    Joined:
    Jul 20, 2010
    #3
    Thanks, but no matter what boot mode we try (holding Shift or CMD+R) it just seems to boot normally and end up at the usual login screen, it feels like we're completely stuck.
     
  4. 0d085d macrumors regular

    Joined:
    Apr 23, 2015
    #4
    I don't mean to patronise, but just to cover all bases:

    Are you certain that you're holding the key down at the right time? Press it as soon as you hear the start up chime, and if that doesn't work, hold it down from before you press the power button.

    ----------

    Also, try a different keyboard. Some of the metal keyboards aren't recognised by the iMac until after boot, by which time it's too late.
     
  5. Jamaway thread starter macrumors member

    Joined:
    Jul 20, 2010
    #5
    Hi - yes - I am holding it down before pressing the power butting and am using an official apple wired keyboard.
     
  6. 0d085d macrumors regular

    Joined:
    Apr 23, 2015
    #6
    Thanks for confirming that - good to clear up the obvious first.

    There are several threads here and there that suggest the standard aluminium keyboard isn't recognised by some ~2007 Macs until after boot due to a bug/oversight. Find another (non-Apple) keyboard and try that. The cheapest most generic keyboard you can find will be your best bet. If it's USB 1.1, even better.

    If you can't get the boot options to work then your only other option will be to physically remove the hard disk and reinstall Yosemite to it from another computer.
     
  7. Jamaway thread starter macrumors member

    Joined:
    Jul 20, 2010
    #7
    Thanks for the advice - I'll try a different keyboard and will report back.
     

Share This Page