iMac 2011 10.8 i7-2700k

Discussion in 'iMac' started by millerg, Nov 16, 2012.

  1. millerg macrumors newbie

    Nov 14, 2012
    I have an imac 2011 and have been running Lion flawlessly on a i7-2700k. I put the i5 back in, upgraded to Mountain lion and a Fusion drive, now I an trying to go back to the 2700k processor.

    If I boot in verbose mode I can see everything happening but as soon as it switches to the grey screen, it crashes.

    If I try and boot in safe mode, it crashed / reboots as well.

    I can start in single user mode.

    Now I'm trying to figure out if it is the Kernel or one or more kernel extensions. The "Hackintosh" users are able to use this processor, so why can't it run in a real Mac?

    The logs show nothing out of the ordinary, they just stop.

    Has anyone tried a modified kernel or kexts?

    Any assistance would be appreciated.

  2. millerg thread starter macrumors newbie

    Nov 14, 2012

    There was a fair bit of luck involved in finding this and I still think I am not out of the woods yet.

    After I was able to startup by holding the D key ( I must have lost AHT when I upgraded to 10.8) I looked at the logs and saw that the last kext to load before the kernel panic was AppleHWSensor. I moved the kext to the desktop and rebuilt the kernel cache and it now starts and runs (so far) fine.

    The question is can I cintunue to run without that kext or do I need a patched on or is there a way to patch it.

    If I load it I get a KP. Is there a way to gather more diagnostic info?

  3. millerg thread starter macrumors newbie

    Nov 14, 2012
    Still running my i7-2700k withe the kext removed. No issues at all but I just ordered a 2600 to ensure future compatibility.

  4. fdtest61 macrumors newbie

    Jan 30, 2013
    Imac 2700k mountain lion Unable to install

    I have a late 2011 IMac which I upgraded to 16 gigs of ram and an Intel Core i7 2700K processor with a Samsung 512 830 SSD but every time I try to install Mountain Lion my imac keeps rebooting and suggestions?

    I assume the mountain lion is rejecting the 2700k cpu?

    Is there a work around?
  5. Vitalemazo macrumors newbie

    Oct 25, 2013
    No I have tried the install with a intel 3770 k on my mid 2011 27 inch imac with samsung 830 ssd the screen won't power on!! I'm back to my 2700k and mavrick but when I reboot mavrick running the 2700k CPU the computer gives me error screen and to press any key to reboot so mavrick and 2700k CPU don't work either unless some one figures out what's causing mavrick and the 2700k CPU glitch or which file to edit again the 3770k i7 intel did not even power in the screen so that was a waste of time trying !

Share This Page