iMac 2017 sleep/wake issue

Discussion in 'iMac' started by spencecb, Jun 6, 2018.

  1. spencecb macrumors 6502a

    spencecb

    Joined:
    Nov 20, 2003
    #1
    Hi all,

    I’ve been noticing a problem with my 2017 iMac 5k when it supposed to be asleep (or power nap, as it is now called). I consistently come into the office with my iMac’s screen on, displaying the lock screen. When I touch the trackpad the screen refreshes, signaling it thought the display was off, to display the lock screen again and then tells me it is unlocking with my Apple Watch.

    Anyone else seeing this or know of a fix? I’ve only has this iMac for about two months, and it has received two macOS updates since. Since the hardware is a year old, I’m wondering if this is a new macOS problem others have experienced?

    Thanks in advance!
     
  2. NajamQ macrumors member

    Joined:
    Apr 30, 2018
    #2
    It's probably sensing your Apple Watch before you enter into the office. Remember bluetooth has a range of 100'.

    Try disabling the watch unlock feature or turn off watch to see how it behaves.
     
  3. spencecb thread starter macrumors 6502a

    spencecb

    Joined:
    Nov 20, 2003
    #3
    Good suggestion, but that’s definitely not it. It does it when I’m not home. My partner has asked me before “are you doing something with your computer remotely, because the screen keeps turning on?”

    Also, that doesn’t explain the screen refresh when I click the trackpad. If it was sensing my Apple Watch, it would just unlock. Also, I don’t believe that’s how the unlocking process works with Apple Watch. You are supposed to click the trackpad/keyboard to wake the computer, then it senses the Apple Watch and unlocks for you. Could you imagine how much of a problem it would be if your computer just unlocked because it detected your Apple Watch, yet you’re in a completely different location in your house?
     
  4. NajamQ, Jun 6, 2018
    Last edited: Jun 6, 2018

    NajamQ macrumors member

    Joined:
    Apr 30, 2018
    #4
    It's
    It's not supposed to do that. Try to uncheck everything in Energy Saver Settings, and reduce turn display off after to about 1 or 2 minutes, disconnect your LAN or WiFi (Turn off). Disconnect all USB devices and turn off mouse and keyboard (5 sec power button) and turn off your Apple watch. Then stay in room and notice what it does after you put it to sleep or when display sleeps.

    If it still does the same thing, then you may try resetting PRAM
    https://support.apple.com/en-us/HT204063

    Your sound and brightness settings or default startup disk will be reset after this. Don't change anything and test again to see if problem goes away.
     

Share This Page