iMac 21" 2011 SSD problems

Discussion in 'iMac' started by steve2237, Oct 13, 2013.

  1. steve2237 macrumors newbie

    Joined:
    Apr 21, 2008
    #1
    I am trying to add a SSD to my computer for a DIY fusion drive. I'm using a 250gb Samsung 830, and the OWC cable kit. After I installed the drive, my computer refused to boot. If I disconnect the SSD, the iMac will boot normally. I tested the SSD in a USB enclosure, so I know it's not faulty. I disconnected my optical drive and tried plugging the SSD into those terminals on the motherboard, but got the same results. Has anyone had similar issues?
     
  2. TheBSDGuy macrumors 6502

    Joined:
    Jan 24, 2012
    #2
    I would suspect the drive is pre-formatted for a Windoze format, which is a guess. Mac's don't necessarily support ALL Windoze formats, but a lot of vendors send them out pre-formatted like that because of their huge market share. You'd need to contact the vendor or visit their web site for confirmation. That's what I would do first.

    Another possibility is that the drive itself isn't recognized properly by the system. You might want to try the following reset to make the system acknowledge the drive:

    http://support.apple.com/kb/HT1379

    That's what I would do second.

    If that doesn't work you might want to evaluate some of the documents or even call the guys at the following company:

    http://scsc-online.com

    Look at some of the stuff in their downloads section, it might be of help to you. If needed, give them a call. If they have time they might help you out. I work with them all the time, but then again I'm a repeat customer, so I'm biased.

    FWIW, a local store had a "fire sale" on some SanDisk SSDs so I bought a small 64G one just to play with. First I did a raw SSD single drive config, which, as expected, hauled, but it didn't have adequate space. Then I did the Core Storage approach as described in the following article:

    http://reviews.cnet.com/8301-13727_7-57550128-263/how-to-make-a-custom-corestorage-drive-in-os-x/

    One difference, maybe, is that because I did a raw SSD install first I did the reset (Apple link above) before I did anything else. To be quite honest, I don't remember if the drive was pre-formatted for DOS/Windoze, I just went ahead and reformatted it as HFS+.

    The Core Storage approach is still much faster than a typical HD, but it's not anywhere near as fast as a raw, standalone SSD. I would compare it to a high speed RAID unit, but you need to keep backups.

    I'm paranoid about SSDs because I've read too many posts on too many web sites about them "losing everything" for no apparent reason. Core Storage works by constantly moving files from the SSD to the HD and back (at least I think it does), depending on use, and if one component fails, it's sort of like a RAID 0 failure...all is lost.

    If you get the thing working I think you'll be happy with it. Mine boots ML in about 30 seconds, whereas an HD takes over a minute. If you're also automatically loading previously running programs, once again, night and day compared to a regular HD.

    I think the future of traditional HDs is to be backup devices.
     
  3. kgian macrumors regular

    Joined:
    Jul 17, 2011
    #3
    What happens when you press the power button? dark screen? beeps? no power at all? do you get the grey apple screen?
     
  4. steve2237 thread starter macrumors newbie

    Joined:
    Apr 21, 2008
    #4
    I get absolutely nothing when I hit the power button with the SSD installed. No fans come on, the main HD does not spin up, and the screen does not light up. Its basically as if the computer was unplugged - zero activity.
     
  5. kgian macrumors regular

    Joined:
    Jul 17, 2011
    #5
    And if you just disconnect the power and data cable from the ssd everything just works? Try that again and if this is the case then your ssd seems to have major hardware problems.

    I mysaelf have installed a vertex 3 240gb in my 21.5 2011 model with no problems from the start...
     
  6. TheBSDGuy macrumors 6502

    Joined:
    Jan 24, 2012
    #6
    If the SSD is working properly in a USB enclosure, it implies to me that the problem is with the cabling. I thought from your original post that you simply meant the system didn't recognize the drive. If it isn't even letting the system power up then it implies the problem is with the cable...at least based on what you've said.

    The "zero activity" you're reporting is typical of a short circuit and the power supply automatically putting itself into shutdown mode for whatever voltage line is being effected (or all, there are several). Does this happen only with the OWC cable?
     
  7. steve2237 thread starter macrumors newbie

    Joined:
    Apr 21, 2008
    #7
    As part of my troubleshooting I tried a few things.

    1) used a second sata cable (same power cable, as i didn't have an alternate), plugged into the spare jumpers on the mainboard

    2) tried two different sata cables, and the same power cable plugged into the optical drive's jumpers on the mainboard

    3) unplugged all additional cables that i had added. unplugged my stock 3.5" hd, and plugged the SSD in place of the hd.

    All of these gave the same result of not booting. Does this sound like there might be a short in the 3-pin power cable from my OWC kit?

    Also, in my first post when I mentioned that I had tested the SSD in an enclosure, well that wasn't actually me. I had taken the computer into an independent repair shop when this first happened, and that guy figured out that it was the SSD keeping the computer from booting. He told me that he tried the SSD in a USB enclosure on another computer and that it worked, but I'm going to borrow some cables and verify that for myself tonight.
     
  8. kgian macrumors regular

    Joined:
    Jul 17, 2011
    #8
    Try the original cables with the ssd and then with the original hdd.

    a) If it boots with the HDD then there is something very wrong with the ssd.

    b) If it won't boot with the original hdd then something is wrong with the computer. Maybe you forgot to plug some cable or you broke something.

    c) if it boots with the hdd and the ssd using the original cables then there is something wrong with the power cable provided from owc..
     
  9. TheBSDGuy macrumors 6502

    Joined:
    Jan 24, 2012
    #9
    Well, that just plain sucks. Apparently you have either a bad cable assembly or, worse yet, a bad SSD. You get your hopes up and, if you're like me, get all excited about a new, cool project and then it apparently falls flat on it's face because you got a bad component. It happens, and really only rarely for most people, but it does happen. That is so annoying. I truly feel for you.

    As one last shot, make sure, seriously make sure a screw or something conductive didn't break loose and is making contact between one or more logic board traces. Aside from trying to isolate the cable or the SSD as the actual problem, that's about all I can think of.

    Hope this helps you, and you have my best wishes.
     
  10. steve2237 thread starter macrumors newbie

    Joined:
    Apr 21, 2008
    #10
    Thanks for all the suggestions guys. I plugged the SSD in using a USB adapter, and it runs fine. I think I've narrowed it down to being a short in the power cable from the OWC kit. I contacted OWC and requested a replacement. On the plus side, my computer works fine when I put it all back together without any of the the new equipment, so at least I'm not dead in the water while I try to get this upgrade sorted out.
     
  11. kgian macrumors regular

    Joined:
    Jul 17, 2011
    #11
    Did you try the ssd in place of the original hdd?
    Seems like your new power cable is faulty...
     
  12. steve2237 thread starter macrumors newbie

    Joined:
    Apr 21, 2008
    #12
    Thanks to everyone that helped me out last week. I emailed OWC and told them I thought the sata power cable from their kit was shorting my computer, and they shipped me out a replacement. Tonight I finally had time to open up the iMac and swap the cable, and it worked like a charm!!!!
     
  13. kgian macrumors regular

    Joined:
    Jul 17, 2011

Share This Page