iMac 21.5" '09 Screen Problems [Read Full Story]

Discussion in 'iMac' started by iMacBoy, Jan 29, 2011.

  1. iMacBoy macrumors 6502

    Joined:
    Dec 24, 2009
    #1
    Hi, this is going to be a fairly long post, so thanks to anyone who bothers to read it.

    I got my iMac on Boxing Day 2009 and it worked perfectly and i loved it.
    Later on in 2010 (September - October) i got a black line down left hand side of screen. I did not drop it or move it or anything.. I left it for a few months because i thought it would disappear itself. After New Year (2011) i sent it back to Apple (Well where apple told me to send it) an Apple Retail Store in chester. Now 10 days later (Today) i have been lost without it and finally got it back. (they said the put a brand new front screen on it). Worked fine the first time i started it up, then i shut it off and went out for a while, came back later on and booted it up. It came onto the white loading screen and made the chime noise, then where it would usually go to the main screen with the dock it just went black, i could hear the fans still running. Now after ages being on the phone too apple, it turns out none of there solutions have worked. Now a few weeks ago i bought a Mini Display Port to VGA adapter to connect an external monitor to my iMac, so i plugg that into my imac with the external monitor and started the iMac.. Now the iMac remained on a black screen doing nothing (fans etc still running) and the external monitor came on... It had the dock and menu bar on the external monitor. I went to displays in system preferences and it was saying this was the only display and it was like it thought that it was the iMac. Usually when i did dual screen when my imac was working the dock would be on the imac etc and it would give me the option the mirror the monitors or whatever and it would let me move the second display to whereever i wanted. But this time with the iMac display not working it didnt recognise that there was an iMac display there if you like.

    Does anyone have a solution to what this is, because i would of thought that if it was a preblem with the 'new screen' it would have worked as normal but you wouldnt be able to see anything cos the screen would be black.
    But thats not how its working because there are a few other things that are happening
    1. Chime is not playing on start up
    2. External display shows as 'only display'

    I am taking it back to the apple retail store, and i hope that this time they fix it and not make it any more worse that it already it.

    Really really annoyed with it right now, thanks anyone who has read this.
     
  2. peskaa macrumors 68020

    peskaa

    Joined:
    Mar 13, 2008
    Location:
    London, UK
    #2
    Just take it back to Apple and explain. They'll fix it. Sounds like the internal display is broken.
     
  3. iMaccore2 macrumors regular

    Joined:
    Mar 2, 2008
    Location:
    Boston, MA
    #3
    If the main display does not show up in system preferences I would say the replacement display was not properly connected. Either way, take it to an apple store and they will fix you up.
     

Share This Page