iMac 21.5 (2010) Mini Display Port to HDMI (Half working HELP!)

Discussion in 'Mac Accessories' started by EB2600, May 18, 2011.

  1. EB2600 macrumors newbie

    Joined:
    May 18, 2011
    #1
    I can't get my Mini Display Port to HDMI to work in OS X but it works fine in Windows. This is driving me mad. The OS X knows it's there and I can change the resolution and move the mouse to the other monitor but nothing shows up on my other monitor. It just stays asleep the whole time. In windows it works 100% of the time both at the same time with no problems at all. Note: I have a iMac 21.5 3.06 i3. (2010):mad:
     
  2. innominato5090 macrumors 6502

    innominato5090

    Joined:
    Sep 4, 2009
    #2
    have you installed bootcamp's drivers that are on the grey DVD that comes with your mac?
     
  3. 8CoreWhore macrumors 68020

    8CoreWhore

    Joined:
    Jan 17, 2008
    Location:
    Big D
    #3
    Def make sure you have latest bootcamp drivers.
     
  4. EB2600 thread starter macrumors newbie

    Joined:
    May 18, 2011
    #4
    Driver problem in OS X

    This has nothing to do with BootCamp. It worked fine it Windows and did not work in the OS X. I fixed it if anyone runs into this problem. Seems to have tons of people that have this problems with no answers.

    • Went to Best Buy
    • Paid for a DYNEX Mini DisplayPort to HDMI Adapter ($25)
    • Came home and plugged in the adapter then the HDMI to DVI cable to the monitor. (Note: Monitor is a LG Flatron L22WTG) - DID NOT WORK
    • iMac knows monitor is plugged in and I can change the resolution on both monitors and mirror. (Note: Changed to every resolutions with/without mirror image.) - DID NOT WORK
    • Restarted computer - DID NOT WORK
    • Turned off/on LG monitor many times - DID NOT WORK
    • Unplugged/plugged back in many different ways - DID NOT WORK
    • Changed the HDMI to DVI cable with a better cable - DID NOT WORK
    • Installed BootCamp with Windows 7 - *BOTH WORK 100%*
    • Rebooted to OS X 10.6.7 (Snow Leopard) - DID NOT WORK
    • Installed Windows XP - *BOTH WORKED 100%*
    • Reinstalled OS X 10.6.4 (Snow Leopard) - *BOTH WORKED 100%*
    • Updated OS X from 10.6.4 to 10.6.7 - DID NOT WORK

    Seems to be a driver problem with the new update (10.6.7). I will not update again till drivers are fixed.
     

Share This Page