iMac 21.5 white screen after every restart

Discussion in 'iMac' started by thewiccaman, Nov 11, 2010.

  1. thewiccaman macrumors member

    thewiccaman

    Joined:
    Jul 14, 2008
    Location:
    East Midlands, UK
    #1
    This is perplexing me: I've only had my iMac 21.5" for a week. I posted here about the white screen issue after the 1st s/w update.

    Now, on every restart I get the same *but only when* my USB ext HDD is plugged in; unplug it & it starts fine, plug HDD in and it mounts, checked external HDD with disk utility - AOK.

    Never had this problem with my old 20" iMac!

    Any suggestions? It's still in DoA period so is it best to get it swapped out?

    Thanks in anticipation
     
  2. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #2
    Try going to System Preferences, Startup Disk, select your iMac's internal hard drive as the startup disk. Then see if the problem persists when the external is connected as I'm thinking it's checking to see if it should be booting from the external hard drive.
     
  3. thewiccaman thread starter macrumors member

    thewiccaman

    Joined:
    Jul 14, 2008
    Location:
    East Midlands, UK
    #3
    I did actually try that & it made no difference :(

    Also tried resetting the 'SMC (?) by removing the power cord, etc.

    Interestingly, unless I was doing it wrong, I attempted resetting PRAM but nothing happened.
     
  4. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #4
    Here's Apple's Doc on resetting both PRAM and NVRAM:

    :apple: Resetting your Mac's PRAM and NVRAM

    I usually allow it to chime 3-4 times rather than the 2 they say just to be sure.

    Here's Apple's Doc on resetting the SMC:

    :apple: Intel-based Macs: Resetting the System Management Controller (SMC)

    Lastly this Apple Doc may be helpful:

    :apple: Resolve startup issues and perform disk maintenance with Disk Utility and fsck
     

Share This Page