iMac 21.5''2010 model - Black screen on start up! Please Help!

Discussion in 'iMac' started by njs083, May 6, 2011.

  1. njs083 macrumors newbie

    Joined:
    May 6, 2011
    #1
    Hi,

    Today I received my new iMac and all excitement dissapated the moment I tried booting up my iMac for the very first time.

    There is a noise coming from the iMac (guess it's the fans) but the screen simply stays black. Nothing happens. No lights, no beeps - nothing.

    What could be the issue? I tried doing the PRAM thing but with no luck. Is this a dudd or am I simply doing something wrong.

    It's my very first iMac purchase so not happy at the moment.

    Thanks - help will be greatly appreciated!
     
  2. njs083 thread starter macrumors newbie

    Joined:
    May 6, 2011
  3. jukeofurl, May 7, 2011
    Last edited: May 7, 2011

    jukeofurl macrumors newbie

    Joined:
    May 6, 2011
    #3
    Not sure...

    Did you turn on your wireless keyboard & mouse first, before using the power button on the computer? you need to do that. ( Yeah I know tricky...) They should light up if the batteries work. (Batteries could be a second part of the problem, if it still fails to boot. Then you'll need to deal with new batteries. Or make sure they are in there!)

    It takes a few seconds to synch or pair the mouse & keybd. ( 5+/- secs ) so it might take a few tries. Once they are lit - push the power button on. You should hear an audible tone. Then click mouse. Hope that works. If it boots you'll obviously know - you get the Set Up Assistant screen.

    If not, sorry - call Apple & have them talk you through it - you'll at least have them to help find out whatever is wrong.
     

Share This Page